summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/subexec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/subexec')
-rw-r--r--dev-ruby/subexec/Manifest1
-rw-r--r--dev-ruby/subexec/metadata.xml8
-rw-r--r--dev-ruby/subexec/subexec-0.2.3-r1.ebuild33
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/subexec/Manifest b/dev-ruby/subexec/Manifest
new file mode 100644
index 000000000000..1caeab99d3cf
--- /dev/null
+++ b/dev-ruby/subexec/Manifest
@@ -0,0 +1 @@
+DIST subexec-0.2.3.tgz 4384 SHA256 c551289af68d4f532e2cddd21466a645c9fd7da55f8c1c3d86c482d63b5d30f8 SHA512 b6fc5ee802906a690a1d1542ada44aba1df5e6861a66f4df58623e366d8d3ab2349d2963817bf07089e1dc15932ca03f0020d16777012ec4b92879280868bb75 WHIRLPOOL 46ec2fb4bb31a66e730aa3fffc048616471495e5730ceb2a5b3077f5b6f388949fedc05576f84dc0961d65945d8087d5c763c7f82695fd3a95b669411f771d49
diff --git a/dev-ruby/subexec/metadata.xml b/dev-ruby/subexec/metadata.xml
new file mode 100644
index 000000000000..4554c42496a7
--- /dev/null
+++ b/dev-ruby/subexec/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">nulayer/subexec</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/subexec/subexec-0.2.3-r1.ebuild b/dev-ruby/subexec/subexec-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..4fe7aaac98f5
--- /dev/null
+++ b/dev-ruby/subexec/subexec-0.2.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem eutils
+
+GITHUB_USER="nulayer"
+
+DESCRIPTION="Subexec spawns an external command with a timeout"
+HOMEPAGE="http://github.com/nulayer/subexec"
+SRC_URI="http://github.com/${GITHUB_USER}/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda )"
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+ sed -i -e '/begin/,/end/ s:^:#:' spec/spec_helper.rb || die
+}