summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/typhoeus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/typhoeus')
-rw-r--r--dev-ruby/typhoeus/Manifest3
-rw-r--r--dev-ruby/typhoeus/metadata.xml5
-rw-r--r--dev-ruby/typhoeus/typhoeus-0.6.9.ebuild31
-rw-r--r--dev-ruby/typhoeus/typhoeus-0.7.1.ebuild30
-rw-r--r--dev-ruby/typhoeus/typhoeus-0.7.2.ebuild30
5 files changed, 99 insertions, 0 deletions
diff --git a/dev-ruby/typhoeus/Manifest b/dev-ruby/typhoeus/Manifest
new file mode 100644
index 000000000000..adc3a65b2951
--- /dev/null
+++ b/dev-ruby/typhoeus/Manifest
@@ -0,0 +1,3 @@
+DIST typhoeus-0.6.9.gem 49152 SHA256 5979555fd430ebec72ab1f5630e8f7679979fb21984d8d9dfe3008d4f91794c8 SHA512 5063d3217f35db29d216327b6eed10d6613d018c496935e78aa8e2b10ec21f3372df11fe48155b45387767d5572efa93e74afb0bb9b10782d28e87dead0294a4 WHIRLPOOL a20d25696804d2d444fa6df145360056dd6170ace42a8cab0a84aa425ae7306173331db8ace402f4a1c596925ee8d52702bc91c967f943361a2a852170b03917
+DIST typhoeus-0.7.1.gem 50688 SHA256 e81bb253477dd527733b2b512e4f48f474e63efe0e41bb92b119e1442fdad3c7 SHA512 e88656fa2a89da9eed5364a7f4249729a0a28835606211249413e48c481d58a8ee7a5267ea2c2d4d1b7947bab979c1223c4481d78ed1bfe34ea7e3b074dcbf78 WHIRLPOOL 2df03d6fe150b5b2a4892740f045eb1317d1c7650ad83675a4498470c1f6169f023f831f2501edee1d1b9d55e6ca08af43440fd00a2d4b109a2c794e61dc4606
+DIST typhoeus-0.7.2.gem 51712 SHA256 073fc5b57a49c17cfa0fda61573a4b590b21bd0c27aed9fb6bee432a024644c3 SHA512 bb672b26aa4639b3b7a7b348a564079211710818a711c58522f94125c92776d398cfd8bde8e519484ac6fe4c7c7a2778d34b8f6579ebff6f842f32caa31e2431 WHIRLPOOL 987cf3ecc6cbbf9a6c9c46580711aa1da9629fa0a22ff3df6d34047a7a83bf0e9a8c0a2ceba816075b27a822d50e8b7be3375ad047b4853a830109bc12844cd7
diff --git a/dev-ruby/typhoeus/metadata.xml b/dev-ruby/typhoeus/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/typhoeus/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/typhoeus/typhoeus-0.6.9.ebuild b/dev-ruby/typhoeus/typhoeus-0.6.9.ebuild
new file mode 100644
index 000000000000..c5e290f7e2e5
--- /dev/null
+++ b/dev-ruby/typhoeus/typhoeus-0.6.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Typhoeus runs HTTP requests in parallel while cleanly encapsulating
+handling logic."
+HOMEPAGE="http://rubygems.org/gems/typhoeus/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/ethon-0.7.1"
+
+ruby_add_bdepend "test? ( dev-ruby/json >=dev-ruby/faraday-0.9 >=dev-ruby/sinatra-1.3 )"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/typhoeus/typhoeus-0.7.1.ebuild b/dev-ruby/typhoeus/typhoeus-0.7.1.ebuild
new file mode 100644
index 000000000000..427a5b9e9d83
--- /dev/null
+++ b/dev-ruby/typhoeus/typhoeus-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Runs HTTP requests in parallel while cleanly encapsulating handling logic"
+HOMEPAGE="http://rubygems.org/gems/typhoeus/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/ethon-0.7.1"
+
+ruby_add_bdepend "test? ( dev-ruby/json >=dev-ruby/faraday-0.9 >=dev-ruby/sinatra-1.3 )"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/typhoeus/typhoeus-0.7.2.ebuild b/dev-ruby/typhoeus/typhoeus-0.7.2.ebuild
new file mode 100644
index 000000000000..9f52ee7dc194
--- /dev/null
+++ b/dev-ruby/typhoeus/typhoeus-0.7.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Runs HTTP requests in parallel while cleanly encapsulating handling logic"
+HOMEPAGE="http://rubygems.org/gems/typhoeus/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/ethon-0.7.4"
+
+ruby_add_bdepend "test? ( dev-ruby/json >=dev-ruby/faraday-0.9 >=dev-ruby/sinatra-1.3 )"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}