summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-21 09:56:01 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-23 07:27:56 +0200
commit36cc5b4c64e410376a678c5a17858300f4a71054 (patch)
tree7418ad0be668f5feae477ac8ab3dd94b18c30824 /dev-ruby
parentdev-ruby/json_schema: avoid bundler dependency (diff)
downloadgentoo-36cc5b4c64e410376a678c5a17858300f4a71054.tar.gz
gentoo-36cc5b4c64e410376a678c5a17858300f4a71054.tar.bz2
gentoo-36cc5b4c64e410376a678c5a17858300f4a71054.zip
dev-ruby/faraday: cleanup
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/faraday/Manifest2
-rw-r--r--dev-ruby/faraday/faraday-0.15.4.ebuild71
-rw-r--r--dev-ruby/faraday/faraday-0.17.1.ebuild62
3 files changed, 0 insertions, 135 deletions
diff --git a/dev-ruby/faraday/Manifest b/dev-ruby/faraday/Manifest
index 962a0a34d45b..008220535298 100644
--- a/dev-ruby/faraday/Manifest
+++ b/dev-ruby/faraday/Manifest
@@ -1,3 +1 @@
-DIST faraday-0.15.4.tar.gz 67196 BLAKE2B 4e64e834639a6e59c028ee19d72f51ea72fd6b3be5fc63b6fbbec25716dbd735e97d8a05a210dd1a57b740a1dcd76d30a39b59c7034cab8a531f8856dc132b14 SHA512 6d1a8c66bd6e2ce417ce504bf20ea89cf24c46c2b48491aba110d04f273448e0e8f0cf94a0dd5356a13876aa030d41bbfb80b95365ea4b212fd79d8db624128f
-DIST faraday-0.17.1.tar.gz 75748 BLAKE2B 203f8603ef24846732b7a41f7a8ad4583539b45958773495c8f1b7f96461c4b661fa13ade0ce5d407b8f6efc17c997a4628cdcb77316ccd7baa2f3a8d6915a85 SHA512 b91079cce459d714e518cd2d45e355e0faf4e79b94a91eff6b9aa67e1a534ff52ee8daea6c21c171804a14a0ae8b18eaf79fd1a8d6ea7b733cc537bceb183970
DIST faraday-0.17.3.tar.gz 76786 BLAKE2B 0706f4386233861564aa1ba5fb8da9ad374a0b553a3f6ccd4ce6509b690f6da3e9f695f90605e0e15b41b6354841943ecc4f5eb826638565687bf62b36f1f456 SHA512 346e93b5d980626a0c460d9010ca09091faf84a1a8f2717c16d345ddc51585ce45959d7fcf41fbd0ba248d38460939544945fa0e81bcb80ab73dfe080182e325
diff --git a/dev-ruby/faraday/faraday-0.15.4.ebuild b/dev-ruby/faraday/faraday-0.15.4.ebuild
deleted file mode 100644
index a0fa609575de..000000000000
--- a/dev-ruby/faraday/faraday-0.15.4.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="HTTP/REST API client library with pluggable components"
-HOMEPAGE="https://github.com/lostisland/faraday"
-SRC_URI="https://github.com/lostisland/faraday/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND+=" test? ( sys-process/lsof )"
-
-ruby_add_rdepend ">=dev-ruby/multipart-post-1.2.0 <dev-ruby/multipart-post-3"
-ruby_add_bdepend "test? (
- >=dev-ruby/test-unit-2.4
- dev-ruby/httpclient
- dev-ruby/rack-test
- dev-ruby/sinatra
- dev-ruby/net-http-persistent >=dev-ruby/connection_pool-2.2.2
- dev-ruby/patron
- )"
-
-all_ruby_prepare() {
- # Remove bundler support.
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d ; 1irequire "yaml"' Rakefile test/helper.rb || die
- sed -i -e '/bundler/,/^fi/ s:^:#:' script/test || die
-
- # Remove simplecov and coveralls support, not needed to run tests.
- sed -i -e '/simplecov/,/^end/ s:^:#:' \
- test/helper.rb || die
-
- # Remove tests for adapters that are not packaged for Gentoo.
- rm test/adapters/em_http_test.rb test/adapters/em_synchrony_test.rb test/adapters/excon_test.rb test/adapters/typhoeus_test.rb || die
-
- # Remove tests against live services
- sed -i -e '/test_dynamic_no_proxy/askip "live network test"' test/connection_test.rb || die
-
- # The proxy server is already killed, may be OS X vs Linux issue.
- sed -i -e '138 s/^/#/' script/test || die
-
- sed -i -e '/git ls-files/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_prepare() {
- # Make sure the test scripts use the right ruby interpreter
- sed -i -e 's:ruby:'${RUBY}':' script/* || die
-}
-
-each_ruby_test() {
- MT_NO_PLUGINS=true each_fakegem_test
-
- # Sleep some time to allow the sinatra test server to die
- einfo "Waiting for test server to stop"
- sleep 10
-}
diff --git a/dev-ruby/faraday/faraday-0.17.1.ebuild b/dev-ruby/faraday/faraday-0.17.1.ebuild
deleted file mode 100644
index 545dbb4d61df..000000000000
--- a/dev-ruby/faraday/faraday-0.17.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="none"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="HTTP/REST API client library with pluggable components"
-HOMEPAGE="https://github.com/lostisland/faraday"
-SRC_URI="https://github.com/lostisland/faraday/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND+=" test? ( sys-process/lsof )"
-
-ruby_add_rdepend ">=dev-ruby/multipart-post-1.2.0 <dev-ruby/multipart-post-3"
-ruby_add_bdepend "test? (
- >=dev-ruby/test-unit-2.4
- dev-ruby/httpclient
- dev-ruby/rack-test
- dev-ruby/sinatra
- dev-ruby/net-http-persistent >=dev-ruby/connection_pool-2.2.2
- dev-ruby/patron
- )"
-
-all_ruby_prepare() {
- # Remove bundler support.
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d ; 1irequire "yaml"' Rakefile || die
- sed -i -e '/bundler/,/^fi/ s:^:#:' script/test || die
- sed -i -e '/[Cc]overall/ s:^:#:' spec/spec_helper.rb || die
-
- # The proxy server is already killed, may be OS X vs Linux issue.
- #sed -i -e '138 s/^/#/' script/test || die
-
- sed -i -e '/git ls-files/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_prepare() {
- # Make sure the test scripts use the right ruby interpreter
- sed -i -e 's:ruby:'${RUBY}':' script/* || die
-}
-
-each_ruby_test() {
- MT_NO_PLUGINS=true each_fakegem_test
-
- # Sleep some time to allow the sinatra test server to die
- einfo "Waiting for test server to stop"
- sleep 10
-}