summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-04-08 16:57:32 +0200
committerAmy Liffey <amynka@gentoo.org>2018-04-08 17:11:16 +0200
commita5a7dd3af6c19e4b5b29ad16d99d90d9f9f33dca (patch)
tree816300e9822737b14aff90e467bf47cd248981ea /dev-scheme/guile
parentapp-text/dvipsk-5.997_p20170524: arm64 stable (diff)
downloadgentoo-a5a7dd3af6c19e4b5b29ad16d99d90d9f9f33dca.tar.gz
gentoo-a5a7dd3af6c19e4b5b29ad16d99d90d9f9f33dca.tar.bz2
gentoo-a5a7dd3af6c19e4b5b29ad16d99d90d9f9f33dca.zip
dev-scheme/guile: remove strip_mask
Closes: https://bugs.gentoo.org/651442 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-scheme/guile')
-rw-r--r--dev-scheme/guile/guile-2.2.3.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/dev-scheme/guile/guile-2.2.3.ebuild b/dev-scheme/guile/guile-2.2.3.ebuild
index e2fad703dca4..895f6d9e02bc 100644
--- a/dev-scheme/guile/guile-2.2.3.ebuild
+++ b/dev-scheme/guile/guile-2.2.3.ebuild
@@ -1,19 +1,21 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit flag-o-matic
+MAJOR="2.2"
DESCRIPTION="GNU Ubiquitous Intelligent Language for Extensions"
HOMEPAGE="https://www.gnu.org/software/guile/"
SRC_URI="mirror://gnu/guile/${P}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
LICENSE="LGPL-3+"
+SLOT="12/2.2-1" # libguile-2.2.so.1 => 2.2-1
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="debug debug-malloc +deprecated +networking +nls +regex +threads" # upstream recommended +networking +nls
-# emacs useflag removal not working
-
-# workaround for bug 596322
-REQUIRED_USE="regex"
+REQUIRED_USE="regex" # workaround for bug 596322
+RESTRICT="strip"
RDEPEND="
>=dev-libs/boehm-gc-7.0:=[threads?]
@@ -29,13 +31,8 @@ DEPEND="${RDEPEND}
sys-apps/texinfo
sys-devel/gettext"
-SLOT="12/2.2-1" # libguile-2.2.so.1 => 2.2-1
-MAJOR="2.2"
-STRIP_MASK="*.go"
-
-DOCS=( GUILE-VERSION HACKING README )
-
PATCHES=( "${FILESDIR}/${P}-gentoo-sandbox.patch" )
+DOCS=( GUILE-VERSION HACKING README )
src_configure() {
# see bug #178499