summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tkdnd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tkdnd')
-rw-r--r--dev-tcltk/tkdnd/Manifest2
-rw-r--r--dev-tcltk/tkdnd/metadata.xml8
-rw-r--r--dev-tcltk/tkdnd/tkdnd-2.2.ebuild41
-rw-r--r--dev-tcltk/tkdnd/tkdnd-2.6.ebuild41
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-tcltk/tkdnd/Manifest b/dev-tcltk/tkdnd/Manifest
new file mode 100644
index 000000000000..9aff0f38f902
--- /dev/null
+++ b/dev-tcltk/tkdnd/Manifest
@@ -0,0 +1,2 @@
+DIST tkdnd2.2.tar.gz 501708 SHA256 89a55e295f8e82829558b4c4548259fbb8a1dc193280b04c2f138bf561a7370f SHA512 96f3b7209d82801b69932531b987cfe2c3367fbaaffd2198afc84bf21643437db8a9958511e31ce2c36896538ff8f8c9237950d0f82b832f7133fb1e5768fd26 WHIRLPOOL 92182d6e54bbbd87e690d77247e6402f76e7dd45eea7cfb318fd104e25d7540534681e0da0e007579af095953fa5989f4f48838f8e6e7da1619176979e97f829
+DIST tkdnd2.6-src.tar.gz 180278 SHA256 e3f499c62d1db2e9a4468791544c784eac727175e094aa06bfe7441dfb3f08e7 SHA512 2ce1be9b49c21bc67102575420311c1ec764493315791c8a76313cae6d22846b3049dd85cdc0b2f28592889432b85103b0fa207445f678dbe22f988eb1d6fc87 WHIRLPOOL b1fc76e0f5d6f91b8a048413f46d0b590ab0f106c4efcf5d26296b2c01ce1586978fda0769da25739a563bec32052030a140c7814f24414612447f3619a69a98
diff --git a/dev-tcltk/tkdnd/metadata.xml b/dev-tcltk/tkdnd/metadata.xml
new file mode 100644
index 000000000000..19c3be566f20
--- /dev/null
+++ b/dev-tcltk/tkdnd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <upstream>
+ <remote-id type="sourceforge">tkdnd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tcltk/tkdnd/tkdnd-2.2.ebuild b/dev-tcltk/tkdnd/tkdnd-2.2.ebuild
new file mode 100644
index 000000000000..1bedea4aec94
--- /dev/null
+++ b/dev-tcltk/tkdnd/tkdnd-2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils eutils
+
+MY_PN="TkDND"
+
+DESCRIPTION="Extension that adds native drag & drop capabilities to the tk toolkit"
+HOMEPAGE="http://www.ellogon.org/petasis/tcltk-projects/tkdnd/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${MY_PN}%20${PV}/${P/-/}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug threads X"
+
+RESTRICT="test"
+
+DEPEND="dev-lang/tk"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/-/}
+
+src_prepare() {
+ sed \
+ -e 's:-O2::g' \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-pipe::g' \
+ -i configure tclconfig/tcl.m4 || die
+}
+
+src_configure() {
+ local myeconfargs
+ use X && myeconfargs+=( --with-x )
+ use debug && myeconfargs+=( --with-symbols )
+ use threads && myeconfargs+=( --enable-threads )
+ autotools-utils_src_configure
+}
diff --git a/dev-tcltk/tkdnd/tkdnd-2.6.ebuild b/dev-tcltk/tkdnd/tkdnd-2.6.ebuild
new file mode 100644
index 000000000000..d42a3cc67eb4
--- /dev/null
+++ b/dev-tcltk/tkdnd/tkdnd-2.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils eutils
+
+MY_PN="TkDND"
+
+DESCRIPTION="Extension that adds native drag & drop capabilities to the tk toolkit"
+HOMEPAGE="http://www.ellogon.org/petasis/tcltk-projects/tkdnd/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${MY_PN}%20${PV}/${P/-/}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug threads X"
+
+DEPEND="dev-lang/tk"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/-/}
+
+RESTRICT="test"
+
+src_prepare() {
+ sed \
+ -e 's:-O2::g' \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-pipe::g' \
+ -i configure tclconfig/tcl.m4 || die
+}
+
+src_configure() {
+ local myeconfargs
+ use X && myeconfargs+=( --with-x )
+ use debug && myeconfargs+=( --with-symbols )
+ use threads && myeconfargs+=( --enable-threads )
+ autotools-utils_src_configure
+}