summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tktray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tktray')
-rw-r--r--dev-tcltk/tktray/Manifest1
-rw-r--r--dev-tcltk/tktray/files/1.1-ldflags.patch13
-rw-r--r--dev-tcltk/tktray/metadata.xml6
-rw-r--r--dev-tcltk/tktray/tktray-1.3.9.ebuild42
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-tcltk/tktray/Manifest b/dev-tcltk/tktray/Manifest
new file mode 100644
index 000000000000..0c899aaa3b05
--- /dev/null
+++ b/dev-tcltk/tktray/Manifest
@@ -0,0 +1 @@
+DIST tktray1.3.9.tar.gz 134484 SHA256 ef48b75ea7979186a05b605f8c153f92bbcc46cb76dee8be1d30bcda179bfcfc SHA512 2c52a343e7f8ff5b7e7bb2e2f1de7766111ce6b47b8ace478a1f2aaa6c28a5b19ec854f2b22511136be1f1da2a87f506932a1d1b893deb3c44a7e47a28609518 WHIRLPOOL cb22a1611f839f604e26061757f978d280faa0b9d0f0ac388c51d686f87f93b7370c43dd1685617ed25ec8d58532ee8e11cc6552e84f677958094fe54b81b9e5
diff --git a/dev-tcltk/tktray/files/1.1-ldflags.patch b/dev-tcltk/tktray/files/1.1-ldflags.patch
new file mode 100644
index 000000000000..0392face2958
--- /dev/null
+++ b/dev-tcltk/tktray/files/1.1-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 9c3945b..c626019 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -107,7 +107,7 @@ OBJEXT = @OBJEXT@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(CFLAGS) $(LDFLAGS)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
+ #TCL_DEFS = @TCL_DEFS@
diff --git a/dev-tcltk/tktray/metadata.xml b/dev-tcltk/tktray/metadata.xml
new file mode 100644
index 000000000000..9b9b332c113b
--- /dev/null
+++ b/dev-tcltk/tktray/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <herd>tcltk</herd>
+</pkgmetadata>
diff --git a/dev-tcltk/tktray/tktray-1.3.9.ebuild b/dev-tcltk/tktray/tktray-1.3.9.ebuild
new file mode 100644
index 000000000000..130603e65fd3
--- /dev/null
+++ b/dev-tcltk/tktray/tktray-1.3.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils virtualx
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="System Tray Icon Support for Tk on X11"
+HOMEPAGE="https://code.google.com/p/tktray/"
+SRC_URI="https://tktray.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="tcltk"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
+IUSE="debug threads test"
+
+DEPEND="
+ >=dev-lang/tcl-8.4:0=
+ >=dev-lang/tk-8.4:0=
+ x11-libs/libXext"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.1-ldflags.patch
+}
+
+src_configure() {
+ source /usr/lib/tclConfig.sh
+ CPPFLAGS="-I${TCL_SRC_DIR}/generic ${CPPFLAGS}" \
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}
+
+src_test() {
+ Xemake
+}