summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-16 20:29:56 +0100
committerMichał Górny <mgorny@gentoo.org>2017-03-18 08:33:28 +0100
commit7a584bfaa9aff1683e665f32b4e7bfa29e53148d (patch)
tree00417211e1508957a8cb2b334d309ce96142ec41 /dev-tcltk
parentwww-apps/roundup: Wipe old (distutils.eclass+sec), #576868 (diff)
downloadgentoo-7a584bfaa9aff1683e665f32b4e7bfa29e53148d.tar.gz
gentoo-7a584bfaa9aff1683e665f32b4e7bfa29e53148d.tar.bz2
gentoo-7a584bfaa9aff1683e665f32b4e7bfa29e53148d.zip
dev-tcltk/snack: Drop old (distutils.eclass)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r5.ebuild105
1 files changed, 0 insertions, 105 deletions
diff --git a/dev-tcltk/snack/snack-2.2.10-r5.ebuild b/dev-tcltk/snack/snack-2.2.10-r5.ebuild
deleted file mode 100644
index 179cabafa55d..000000000000
--- a/dev-tcltk/snack/snack-2.2.10-r5.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit eutils distutils multilib
-
-DESCRIPTION="The Snack Sound Toolkit (Tcl)"
-HOMEPAGE="http://www.speech.kth.se/snack/"
-SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-SLOT="0"
-IUSE="alsa examples python threads vorbis"
-
-RESTRICT="test" # Bug 78354
-
-DEPEND="
- >dev-lang/tcl-8.4.3:0
- >dev-lang/tk-8.4.3:0
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}${PV}/unix"
-
-PYTHON_MODNAME="tkSnack.py"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # bug 226137 - snack depends on alsa private symbol _snd_pcm_mmap_hw_ptr
- epatch "${FILESDIR}"/alsa-undef-sym.patch
- # bug 270839 - error from /usr/include/bits/mathcalls.h:310
- sed \
- -e 's|^\(#define roundf(.*\)|//\1|' \
- -i ../generic/jkFormatMP3.c || die
-
- # adds -install_name (soname on Darwin)
- [[ ${CHOST} == *-darwin* ]] && epatch "${FILESDIR}"/${P}-darwin.patch
-
- # From Fedora
- cd ../
- epatch "${FILESDIR}"/${P}-CVE-2012-6303-fix.patch
-}
-
-src_configure() {
- local myconf="--libdir="${EPREFIX}"/usr/$(get_libdir) --includedir="${EPREFIX}"/usr/include"
-
- use alsa && myconf="${myconf} --enable-alsa"
- use threads && myconf="${myconf} --enable-threads"
-
- if use vorbis ; then
- myconf="${myconf} --with-ogg-include="${EPREFIX}"/usr/include"
- myconf="${myconf} --with-ogg-lib="${EPREFIX}"/usr/$(get_libdir)"
- fi
-
- econf ${myconf}
-}
-
-src_compile() {
- # We do not want to run distutils_src_compile
- default
-}
-
-src_install() {
- default
-
- if use python ; then
- cd "${S}"/../python
- distutils_src_install
- fi
-
- cd "${S}"/..
-
- dohtml doc/*
-
- if use examples ; then
- sed -i -e 's/wish[0-9.]+/wish/g' demos/tcl/* || die
- docinto examples/tcl
- dodoc demos/tcl/*
-
- if use python ; then
- docinto examples/python
- dodoc demos/python/*
- fi
- fi
-}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}