summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/squashdelta
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/squashdelta')
-rw-r--r--dev-util/squashdelta/Manifest1
-rw-r--r--dev-util/squashdelta/metadata.xml19
-rw-r--r--dev-util/squashdelta/squashdelta-0.1.ebuild36
-rw-r--r--dev-util/squashdelta/squashdelta-9999.ebuild48
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-util/squashdelta/Manifest b/dev-util/squashdelta/Manifest
new file mode 100644
index 000000000000..d5d57673555b
--- /dev/null
+++ b/dev-util/squashdelta/Manifest
@@ -0,0 +1 @@
+DIST squashdelta-0.1.tar.bz2 77702 SHA256 732b0c05085d2d2f14329e0edd3a4b4f15ff315b8b47cac553e6be3c5f9f3f5a SHA512 1ce93b59b6c51be49aaaee9576049677c8ba146fa3a17c7d3552440a1c0ebe93fb4d8cbe1182db691e2c9552713ecfeef0e50d95f7e94218c341c51364bf724f WHIRLPOOL 1ff9fe6a653ca394e5fc1d32bf420880d2e2036d11560cf9ad9cf23535d4c8a60758a7da5e81121d8fa5fe053f1cac83d161057a84076327315b1c35a1d30e3a
diff --git a/dev-util/squashdelta/metadata.xml b/dev-util/squashdelta/metadata.xml
new file mode 100644
index 000000000000..9487ce936359
--- /dev/null
+++ b/dev-util/squashdelta/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="lz4">Enable support for LZ4 compression using <pkg>app-arch/lz4</pkg></flag>
+ </use>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/squashdelta/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/squashdelta</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/squashdelta/squashdelta-0.1.ebuild b/dev-util/squashdelta/squashdelta-0.1.ebuild
new file mode 100644
index 000000000000..93cd33b1bd39
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://bitbucket.org/mgorny/squashdelta/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/squashdelta/squashdelta-9999.ebuild b/dev-util/squashdelta/squashdelta-9999.ebuild
new file mode 100644
index 000000000000..54ce642990dc
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://bitbucket.org/mgorny/squashdelta/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ autotools-utils_src_configure
+}