summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-01-09 14:49:15 +0100
committerJohannes Huber <johu@gentoo.org>2016-01-09 14:51:28 +0100
commit143c67084aba220df5bc012fa0decc2cbc58ad40 (patch)
tree6bdac37b68918e3a414fe604babae29305b3aadd /dev-vcs
parentsci-mathematics/spin: version bump (6.4.5); now the license is BSD (diff)
downloadgentoo-143c67084aba220df5bc012fa0decc2cbc58ad40.tar.gz
gentoo-143c67084aba220df5bc012fa0decc2cbc58ad40.tar.bz2
gentoo-143c67084aba220df5bc012fa0decc2cbc58ad40.zip
dev-vcs/git-flow: EAPI 6
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-flow/git-flow-1.8.0-r1.ebuild2
-rw-r--r--dev-vcs/git-flow/git-flow-1.8.0-r2.ebuild40
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-vcs/git-flow/git-flow-1.8.0-r1.ebuild b/dev-vcs/git-flow/git-flow-1.8.0-r1.ebuild
index 7967fb01f6ed..3c7de0d0548f 100644
--- a/dev-vcs/git-flow/git-flow-1.8.0-r1.ebuild
+++ b/dev-vcs/git-flow/git-flow-1.8.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/dev-vcs/git-flow/git-flow-1.8.0-r2.ebuild b/dev-vcs/git-flow/git-flow-1.8.0-r2.ebuild
new file mode 100644
index 000000000000..969188df3e9c
--- /dev/null
+++ b/dev-vcs/git-flow/git-flow-1.8.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/-/}"
+COMP_PN="${PN}-completion"
+COMP_PV="0.5.1"
+COMP_P="${COMP_PN}-${COMP_PV}"
+inherit bash-completion-r1
+
+DESCRIPTION="Git extensions to provide high-level repository operations for Vincent Driessen's branching model"
+HOMEPAGE="https://github.com/petervanderdoes/gitflow"
+SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+DOCS=( AUTHORS Changes.mdown README.mdown )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+ einstalldocs
+ newbashcomp "${WORKDIR}/${COMP_P}/${COMP_PN}.bash" ${PN}
+}