summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2019-06-18 06:45:24 +0200
committerEttore Di Giacinto <mudler@gentoo.org>2019-06-18 08:55:18 +0200
commit258ac0fa8150c71a07553a7dbcd2972008cac346 (patch)
tree4e7d598ab18ba0af05388ea365eddff125136dcd /dev-vcs
parentdev-ada/gnatmem: bump to 2019 (diff)
downloadgentoo-258ac0fa8150c71a07553a7dbcd2972008cac346.tar.gz
gentoo-258ac0fa8150c71a07553a7dbcd2972008cac346.tar.bz2
gentoo-258ac0fa8150c71a07553a7dbcd2972008cac346.zip
dev-vcs/git-lfs: Bump to 2.7.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Ettore Di Giacinto <mudler@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/Manifest1
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.7.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index 7cb3b2cde012..4a9b9a6998ce 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1,2 +1,3 @@
DIST git-lfs-2.5.2.tar.gz 947150 BLAKE2B 08949f14d6292689a00ba693123373b7317a96165fcbd8bf560e81a7e1d03a1ac809cc5273efecce85f017d576107c5e651f2f30331130ecf154c9799394d590 SHA512 58475f833e0ef69d37ece91f3792b43f2a589cce94d1eba22a0534aa40257b236f9f9aab633c8b800bec129eb86fbc38e9ab6b5e52144595a27cd13bee5cb33e
DIST git-lfs-2.6.1.tar.gz 1630301 BLAKE2B c88ee2110fac8d46567b348c9473e3c5d9e4b763b8f03437e2121388f588109f62ea9145e239a619688150acd871c486309dc3a2bc6d046d6c25a0c43c607ebb SHA512 1f45d8da4f67d37e85b061c219423863ed41ed4723dd1030e7287e422d84cd615ddd820765bd32a147264c0f4bf9d5e84185970442fd110ae9656be97de78663
+DIST git-lfs-2.7.2.tar.gz 1672700 BLAKE2B cd370d6b7332187233ed599747d29f917c1d0bb5f5bed72357a4712c38594c28bba976e7e5007623387ac5f668f670801582b2a08cf84f9270be42671e0d1194 SHA512 cd71815eb418b7acaf077de4873ff49d332f71151c1212ca4fe3a2d0e079bad873894bb416488f272777153cc3422deecf17a849cd67f150b44eb094a09ae8be
diff --git a/dev-vcs/git-lfs/git-lfs-2.7.2.ebuild b/dev-vcs/git-lfs/git-lfs-2.7.2.ebuild
new file mode 100644
index 000000000000..ed1c9a5d2cb1
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-2.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/${PN}/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-build golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-build golang-vcs-snapshot
+fi
+
+DESCRIPTION="command line extension and specification for managing large files with Git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
+SLOT="0"
+IUSE="+doc"
+
+DEPEND="doc? ( app-text/ronn )"
+
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ golang-build_src_compile
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin git-lfs
+ use doc && doman docs/man/*.1
+}