summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/armagetronad
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/armagetronad')
-rw-r--r--games-action/armagetronad/Manifest1
-rw-r--r--games-action/armagetronad/armagetronad-0.2.8.3.2.ebuild76
-rw-r--r--games-action/armagetronad/metadata.xml8
3 files changed, 85 insertions, 0 deletions
diff --git a/games-action/armagetronad/Manifest b/games-action/armagetronad/Manifest
new file mode 100644
index 000000000000..30678d89d9b0
--- /dev/null
+++ b/games-action/armagetronad/Manifest
@@ -0,0 +1 @@
+DIST armagetronad-0.2.8.3.2.src.tar.bz2 1841407 SHA256 f444e481de94e6c0e3933c709d46effd2adfe823f5ef44768adcc8003b8ba7c5 SHA512 ffe16d55d4ea3c9e3f4f8828a9ffb09274b20a33c6d5c91cccbe846fa93f7d1d78e565db3c9403debf9f7bfde76322477a84349d85b475ed20c184da281107a4 WHIRLPOOL f04902c7bf3b13ec35497202a658ef96846b59d4245c72a17793b186d06a8f2d2dc1960b563b785cfb46aa9e2252a8ba22436df44e4ccfa2e8c872b4eb51eb4a
diff --git a/games-action/armagetronad/armagetronad-0.2.8.3.2.ebuild b/games-action/armagetronad/armagetronad-0.2.8.3.2.ebuild
new file mode 100644
index 000000000000..405b703a05c8
--- /dev/null
+++ b/games-action/armagetronad/armagetronad-0.2.8.3.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Fast-paced 3D lightcycle game based on Tron"
+HOMEPAGE="http://armagetronad.org/"
+SRC_URI="http://launchpad.net/armagetronad/${PV:0:5}/${PV}/+download/armagetronad-${PV}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dedicated sound"
+
+RDEPEND="
+ dev-libs/libxml2
+ !dedicated? (
+ media-libs/libpng:0
+ media-libs/sdl-image[jpeg,png]
+ virtual/glu
+ virtual/opengl
+ sound? (
+ media-libs/libsdl[X,sound,opengl,video]
+ media-libs/sdl-mixer
+ )
+ !sound? ( media-libs/libsdl[X,opengl,video] )
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's/"png_check_sig"/"png_sig_cmp"/' \
+ -e 's#aa_docdir=.*$#aa_docdir=${docdir}#' \
+ configure || die
+}
+
+src_configure() {
+ # --enable-games just messes up paths
+ egamesconf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable dedicated) \
+ $(use_enable sound music) \
+ --disable-sysinstall \
+ --disable-useradd \
+ --disable-uninstall \
+ --disable-games
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+
+ # misplaced desktop-file/icons
+ rm -rf "${ED%/}${GAMES_DATADIR}"/armagetronad/desktop
+ doicon -s 48 desktop/icons/large/armagetronad.png
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/armagetronad/metadata.xml b/games-action/armagetronad/metadata.xml
new file mode 100644
index 000000000000..3ddf64ba758b
--- /dev/null
+++ b/games-action/armagetronad/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="launchpad">armagetronad</remote-id>
+ </upstream>
+</pkgmetadata>