summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/powermanga/powermanga-0.91.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/powermanga/powermanga-0.91.ebuild')
-rw-r--r--games-action/powermanga/powermanga-0.91.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/games-action/powermanga/powermanga-0.91.ebuild b/games-action/powermanga/powermanga-0.91.ebuild
new file mode 100644
index 000000000000..f76a74c697aa
--- /dev/null
+++ b/games-action/powermanga/powermanga-0.91.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools games
+
+DESCRIPTION="An arcade 2D shoot-em-up game"
+HOMEPAGE="http://linux.tlk.fr/"
+SRC_URI="http://linux.tlk.fr/games/Powermanga/download/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2[sound,joystick,video]
+ media-libs/libpng:0
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86dga
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local f
+ for f in src/assembler.S src/assembler_opt.S ; do
+ einfo "patching $f"
+ cat <<-EOF >> ${f}
+ #if defined(__linux__) && defined(__ELF__)
+ .section .note.GNU-stack,"",%progbits
+ #endif
+ EOF
+ done
+ epatch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-segfault.patch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ sed -i \
+ -e "/scoredir/s#/var/games/powermanga#${GAMES_STATEDIR}#" \
+ src/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf --prefix=/usr
+}
+
+src_install() {
+ newgamesbin src/powermanga powermanga.bin
+ doman powermanga.6
+ dodoc AUTHORS CHANGES README
+
+ insinto "${GAMES_DATADIR}/powermanga"
+ doins -r data sounds graphics texts
+
+ find "${D}${GAMES_DATADIR}/powermanga/" -name "Makefil*" -execdir rm -f \{\} +
+
+ insinto "${GAMES_STATEDIR}"
+ local f
+ for f in powermanga.hi-easy powermanga.hi powermanga.hi-hard ; do
+ touch "${D}${GAMES_STATEDIR}/${f}" || die
+ fperms 660 "${GAMES_STATEDIR}/${f}"
+ done
+
+ games_make_wrapper powermanga powermanga.bin "${GAMES_DATADIR}/powermanga"
+ make_desktop_entry powermanga Powermanga
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "NOTE: The highscore file format has changed."
+ ewarn "Older highscores will not be retained."
+}