summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-24 17:25:27 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-24 17:39:17 -0600
commite1b52c244e7416d879ebafe9aa294c483506bcc4 (patch)
tree616ce663851325b915d7600fc0d910bf5549bef9 /games-action
parentgames-action/fakk2: remove deprecated games eclass (diff)
downloadgentoo-e1b52c244e7416d879ebafe9aa294c483506bcc4.tar.gz
gentoo-e1b52c244e7416d879ebafe9aa294c483506bcc4.tar.bz2
gentoo-e1b52c244e7416d879ebafe9aa294c483506bcc4.zip
games-action/garden: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action')
-rw-r--r--games-action/garden/files/garden-1.0.8-dash.patch4
-rw-r--r--games-action/garden/files/garden-1.0.8-underlink.patch8
-rw-r--r--games-action/garden/files/garden-1.0.9-dash.patch4
-rw-r--r--games-action/garden/files/garden-1.0.9-resources.patch4
-rw-r--r--games-action/garden/garden-1.0.9-r1.ebuild52
5 files changed, 62 insertions, 10 deletions
diff --git a/games-action/garden/files/garden-1.0.8-dash.patch b/games-action/garden/files/garden-1.0.8-dash.patch
index 2d8630236ffb..6b197f4f4e1a 100644
--- a/games-action/garden/files/garden-1.0.8-dash.patch
+++ b/games-action/garden/files/garden-1.0.8-dash.patch
@@ -1,5 +1,5 @@
---- configure.ac.orig 2015-05-04 14:48:03.467935640 -0400
-+++ configure.ac 2015-05-04 14:48:24.729199607 -0400
+--- a/configure.ac 2015-05-04 14:48:03.467935640 -0400
++++ b/configure.ac 2015-05-04 14:48:24.729199607 -0400
@@ -80,7 +80,7 @@
[have_allegro="no"])
AC_MSG_RESULT([$have_allegro])
diff --git a/games-action/garden/files/garden-1.0.8-underlink.patch b/games-action/garden/files/garden-1.0.8-underlink.patch
index bd25a4d57384..e538a61a1c1a 100644
--- a/games-action/garden/files/garden-1.0.8-underlink.patch
+++ b/games-action/garden/files/garden-1.0.8-underlink.patch
@@ -1,5 +1,5 @@
---- bin/Makefile.am.old 2011-06-22 18:16:30.654661047 +0200
-+++ bin/Makefile.am 2011-06-22 18:16:55.662251326 +0200
+--- a/bin/Makefile.am 2011-06-22 18:16:30.654661047 +0200
++++ b/bin/Makefile.am 2011-06-22 18:16:55.662251326 +0200
@@ -9,6 +9,7 @@
garden_LDFLAGS = -static
else #unix version :-)
@@ -8,8 +8,8 @@
endif
#how to build resources?
---- Makefile.am.old 2011-06-22 18:19:37.787560851 +0200
-+++ Makefile.am 2011-06-22 18:19:44.078960907 +0200
+--- a/Makefile.am 2011-06-22 18:19:37.787560851 +0200
++++ b/Makefile.am 2011-06-22 18:19:44.078960907 +0200
@@ -1,5 +1,5 @@
ACLOCAL_AMFLAGS= -I m4
-SUBDIRS = bin resources
diff --git a/games-action/garden/files/garden-1.0.9-dash.patch b/games-action/garden/files/garden-1.0.9-dash.patch
index 2d8630236ffb..6b197f4f4e1a 100644
--- a/games-action/garden/files/garden-1.0.9-dash.patch
+++ b/games-action/garden/files/garden-1.0.9-dash.patch
@@ -1,5 +1,5 @@
---- configure.ac.orig 2015-05-04 14:48:03.467935640 -0400
-+++ configure.ac 2015-05-04 14:48:24.729199607 -0400
+--- a/configure.ac 2015-05-04 14:48:03.467935640 -0400
++++ b/configure.ac 2015-05-04 14:48:24.729199607 -0400
@@ -80,7 +80,7 @@
[have_allegro="no"])
AC_MSG_RESULT([$have_allegro])
diff --git a/games-action/garden/files/garden-1.0.9-resources.patch b/games-action/garden/files/garden-1.0.9-resources.patch
index 6acd6f5f78d5..0ddbdc5e6e30 100644
--- a/games-action/garden/files/garden-1.0.9-resources.patch
+++ b/games-action/garden/files/garden-1.0.9-resources.patch
@@ -1,5 +1,5 @@
---- Makefile.am.orig 2015-05-04 16:57:07.510191036 -0400
-+++ Makefile.am 2015-05-04 16:57:14.581946228 -0400
+--- a/Makefile.am 2015-05-04 16:57:07.510191036 -0400
++++ b/Makefile.am 2015-05-04 16:57:14.581946228 -0400
@@ -1,3 +1,3 @@
ACLOCAL_AMFLAGS= -I m4
diff --git a/games-action/garden/garden-1.0.9-r1.ebuild b/games-action/garden/garden-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..681e2cd2df19
--- /dev/null
+++ b/games-action/garden/garden-1.0.9-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils autotools flag-o-matic
+
+DESCRIPTION="Multiplatform vertical shoot-em-up with non-traditional elements"
+HOMEPAGE="http://garden.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="<media-libs/allegro-5"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dash.patch"
+ "${FILESDIR}/${P}-resources.patch"
+)
+src_prepare() {
+ default
+
+ # build with gcc52
+ sed -i \
+ -e 's/inline/extern inline/' \
+ src/stuff.h || die
+ eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #572672)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README" \
+ default
+ doicon -s scalable resources/garden.svg
+ make_desktop_entry garden "Garden of coloured lights"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}