summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/crack-attack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/crack-attack')
-rw-r--r--games-arcade/crack-attack/Manifest1
-rw-r--r--games-arcade/crack-attack/crack-attack-1.1.14-r1.ebuild45
-rw-r--r--games-arcade/crack-attack/files/crack-attack-1.1.14-gcc43.patch10
-rw-r--r--games-arcade/crack-attack/files/crack-attack-1.1.14-glut.patch14
-rw-r--r--games-arcade/crack-attack/metadata.xml5
5 files changed, 75 insertions, 0 deletions
diff --git a/games-arcade/crack-attack/Manifest b/games-arcade/crack-attack/Manifest
new file mode 100644
index 000000000000..de9cb9a28c5c
--- /dev/null
+++ b/games-arcade/crack-attack/Manifest
@@ -0,0 +1 @@
+DIST crack-attack-1.1.14.tar.bz2 801404 SHA256 1e23e019f8740cd01fb3fbbb7903137b1e8971a8e9d0692da069106b8a0382e8 SHA512 1afc1a59e25359a82cabc33a1f999e1166dcf74c031c29a366f8414989bc7c32b9a40e467ee40a37901f2bd08f4569fed25c4d3021b1a75254614840410a7bfa WHIRLPOOL f0509c015e779bffae0ed7c4ac370fa5d9aa10d9e6546a14468c45f84a9d1de8457cc2b7c45fc479d06101f4424e6d699174b40375ebd6c5c224a707f31df731
diff --git a/games-arcade/crack-attack/crack-attack-1.1.14-r1.ebuild b/games-arcade/crack-attack/crack-attack-1.1.14-r1.ebuild
new file mode 100644
index 000000000000..369b2cedb050
--- /dev/null
+++ b/games-arcade/crack-attack/crack-attack-1.1.14-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Addictive OpenGL-based block game"
+HOMEPAGE="http://www.nongnu.org/crack-attack/"
+SRC_URI="http://savannah.nongnu.org/download/crack-attack/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc sparc x86"
+IUSE="gtk sdl"
+
+RDEPEND="media-libs/freeglut
+ sdl? ( media-libs/libsdl
+ media-libs/sdl-mixer )
+ gtk? ( >=x11-libs/gtk+-2.6:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-glut.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+ sed -i 's/-lXmu//' src/gtk-gui/Makefile.in src/Makefile.in || die
+ touch -r . * */*
+}
+
+src_configure() {
+ egamesconf \
+ --disable-binreloc \
+ $(use_enable sdl sound) \
+ $(use_enable gtk)
+}
+
+src_install() {
+ default
+ dohtml -A xpm doc/*
+ doicon data/crack-attack.xpm
+ make_desktop_entry crack-attack Crack-attack
+ prepgamesdirs
+}
diff --git a/games-arcade/crack-attack/files/crack-attack-1.1.14-gcc43.patch b/games-arcade/crack-attack/files/crack-attack-1.1.14-gcc43.patch
new file mode 100644
index 000000000000..009d062f2eac
--- /dev/null
+++ b/games-arcade/crack-attack/files/crack-attack-1.1.14-gcc43.patch
@@ -0,0 +1,10 @@
+--- src/Game.h
++++ src/Game.h
+@@ -34,6 +34,7 @@
+ #include <climits>
+ #include <cstdlib>
+ #include <cmath>
++#include <cstring>
+
+ #ifdef __MINGW32__
+ # include <windows.h>
diff --git a/games-arcade/crack-attack/files/crack-attack-1.1.14-glut.patch b/games-arcade/crack-attack/files/crack-attack-1.1.14-glut.patch
new file mode 100644
index 000000000000..fc16c1b8bc4e
--- /dev/null
+++ b/games-arcade/crack-attack/files/crack-attack-1.1.14-glut.patch
@@ -0,0 +1,14 @@
+Fix from upstream to work with newer freegluts.
+
+http://bugs.gentoo.org/97954
+
+--- src/Attack.cxx
++++ src/Attack.cxx
+@@ -83,6 +83,7 @@
+ int height = -1, width = -1;
+
+ player_name[0] = '\0';
++ glutInit(&argc, argv);
+ parseCommandLine(argc, argv, mode, port, host_name, player_name, height, width);
+ run_crack_attack(mode, port, host_name, player_name, height, width);
+
diff --git a/games-arcade/crack-attack/metadata.xml b/games-arcade/crack-attack/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/crack-attack/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>