summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/late
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/late')
-rw-r--r--games-arcade/late/Manifest1
-rw-r--r--games-arcade/late/files/late-0.1.0-gcc43.patch11
-rw-r--r--games-arcade/late/files/late-0.1.0-gcc46.patch11
-rw-r--r--games-arcade/late/late-0.1.0.ebuild36
-rw-r--r--games-arcade/late/metadata.xml8
5 files changed, 67 insertions, 0 deletions
diff --git a/games-arcade/late/Manifest b/games-arcade/late/Manifest
new file mode 100644
index 000000000000..86cbce939458
--- /dev/null
+++ b/games-arcade/late/Manifest
@@ -0,0 +1 @@
+DIST late-0.1.0.tar.bz2 1560232 SHA256 76aac8e436e0420642790658129b5a3f27c836c07bd9b6871b3c88aa2f8aff0a SHA512 6b3f4d27a723ae450bd8dda375c8663c1a3f457ffbe0a91f5eb96efdd797c2370ec68894df7a4d31e7124b28f3b41b3b952805901427c6ea3502b0d4d13cd72e WHIRLPOOL 3ebd6f69da7e248fcbf059d8245b1658891ff6ec5cbb1abd118f2cd642fa60c47b0948cbf5256648a8c5672eaf16513fe1f145d697dba882429c6f6696e916f8
diff --git a/games-arcade/late/files/late-0.1.0-gcc43.patch b/games-arcade/late/files/late-0.1.0-gcc43.patch
new file mode 100644
index 000000000000..bce26464cf04
--- /dev/null
+++ b/games-arcade/late/files/late-0.1.0-gcc43.patch
@@ -0,0 +1,11 @@
+--- src/init.cpp
++++ src/init.cpp
+@@ -26,6 +26,8 @@
+ #include "scorescreen.h"
+ #include <fstream>
+ #include <iostream>
++#include <cstdlib>
++#include <cstring>
+ using namespace std;
+
+
diff --git a/games-arcade/late/files/late-0.1.0-gcc46.patch b/games-arcade/late/files/late-0.1.0-gcc46.patch
new file mode 100644
index 000000000000..95d18ba7ed11
--- /dev/null
+++ b/games-arcade/late/files/late-0.1.0-gcc46.patch
@@ -0,0 +1,11 @@
+diff -ru late-0.1.0.orig/src/ball.h late-0.1.0/src/ball.h
+--- late-0.1.0.orig/src/ball.h 2003-08-07 18:26:13.000000000 -0400
++++ late-0.1.0/src/ball.h 2011-04-07 21:32:14.189799689 -0400
+@@ -25,6 +25,7 @@
+ class ball;
+
+ #include "square.h"
++#include <cstddef>
+
+ class ball_base
+ {
diff --git a/games-arcade/late/late-0.1.0.ebuild b/games-arcade/late/late-0.1.0.ebuild
new file mode 100644
index 000000000000..dd05b7b95ed2
--- /dev/null
+++ b/games-arcade/late/late-0.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A game, similar to Barrack by Ambrosia Software"
+HOMEPAGE="http://late.sourceforge.net/"
+SRC_URI="mirror://sourceforge/late/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[jpeg]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
+ sed -i \
+ -e "/chown/d" \
+ Makefile.in \
+ || die "sed failed"
+}
+
+src_install () {
+ default
+ newicon graphics/latebg2.jpg ${PN}.jpg
+ make_desktop_entry late Late /usr/share/pixmaps/${PN}.jpg
+ prepgamesdirs
+}
diff --git a/games-arcade/late/metadata.xml b/games-arcade/late/metadata.xml
new file mode 100644
index 000000000000..e4cbcf411f56
--- /dev/null
+++ b/games-arcade/late/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">late</remote-id>
+ </upstream>
+</pkgmetadata>