summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/xtux
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/xtux')
-rw-r--r--games-arcade/xtux/Manifest1
-rw-r--r--games-arcade/xtux/files/xtux-20030306-ldflags.patch22
-rw-r--r--games-arcade/xtux/files/xtux-20030306-particles.patch30
-rw-r--r--games-arcade/xtux/metadata.xml8
-rw-r--r--games-arcade/xtux/xtux-20030306.ebuild51
5 files changed, 112 insertions, 0 deletions
diff --git a/games-arcade/xtux/Manifest b/games-arcade/xtux/Manifest
new file mode 100644
index 000000000000..0a910c2c4669
--- /dev/null
+++ b/games-arcade/xtux/Manifest
@@ -0,0 +1 @@
+DIST xtux-src-20030306.tar.gz 1640928 SHA256 3ef2c3d7615d05b1d6efa6a99358aa907c5cf635ffb017f5cad59c8d91c47670 SHA512 edb137b4d6b0fe7d673e8eedffbd9c521800a8e51aff0a36e5aa02d46a157d42142326b334b9c7358cfb5debf4b78a2a9951f82121dd538cfe288cf292a269d4 WHIRLPOOL dcb12892afadfedd99bfec15b1df1adb2c1c6b947f12366155832cd5303977dd79ae4f9434b4948e45a3b08ed12cbb4e7655741ec8b5add1e3f7e794a598aeae
diff --git a/games-arcade/xtux/files/xtux-20030306-ldflags.patch b/games-arcade/xtux/files/xtux-20030306-ldflags.patch
new file mode 100644
index 000000000000..d2c798d0795d
--- /dev/null
+++ b/games-arcade/xtux/files/xtux-20030306-ldflags.patch
@@ -0,0 +1,22 @@
+--- src/client/Makefile.old 2010-09-30 18:08:16.000000000 +0200
++++ src/client/Makefile 2010-09-30 18:08:41.000000000 +0200
+@@ -48,7 +48,7 @@
+
+ #Apps
+ client: $(OBJECTS)
+- $(CC) -o $(BINARY) $(CFLAGS) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(X11LIB) $(XPMLIB) $(SOCKLIB) $(GGZLIB)
++ $(CC) -o $(BINARY) $(LDFLAGS) $(CFLAGS) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(X11LIB) $(XPMLIB) $(SOCKLIB) $(GGZLIB)
+
+ # OBJECTS
+ .c.o: client.h $*.c
+--- src/server/Makefile.old 2010-09-30 18:09:55.000000000 +0200
++++ src/server/Makefile 2010-09-30 18:10:16.000000000 +0200
+@@ -41,7 +41,7 @@
+
+ #Apps
+ server: $(OBJECTS)
+- $(CC) -o $(BINARY) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(SOCKLIB) $(GGZLIB)
++ $(CC) $(LDFLAGS) -o $(BINARY) $(OBJECTS) $(XTUXLIB) $(MATHLIB) $(SOCKLIB) $(GGZLIB)
+
+ # OBJECTS
+ .c.o: server.h $*.h $*.c
diff --git a/games-arcade/xtux/files/xtux-20030306-particles.patch b/games-arcade/xtux/files/xtux-20030306-particles.patch
new file mode 100644
index 000000000000..9a340821dd6e
--- /dev/null
+++ b/games-arcade/xtux/files/xtux-20030306-particles.patch
@@ -0,0 +1,30 @@
+diff -u -r xtux.old/src/client/particle.c xtux/src/client/particle.c
+--- xtux.old/src/client/particle.c 2008-09-02 20:34:24.000000000 +0200
++++ xtux/src/client/particle.c 2008-09-02 20:35:40.000000000 +0200
+@@ -340,11 +340,11 @@
+ ptl->pos[i].y = src_y;
+ d = dir + 128;
+ d += i%SHARD_ANGLE - SHARD_ANGLE/2;
+- ptl->vel[i].x = sin_lookup[dir + 64 + rand()%64] * SHARD_EXP_VEL;
+- ptl->vel[i].y = -cos_lookup[dir + 64 + rand()%64] * SHARD_EXP_VEL;
++ ptl->vel[i].x = sin_lookup[(dir + 64 + rand()%64) % DEGREES] * SHARD_EXP_VEL;
++ ptl->vel[i].y = -cos_lookup[(dir + 64 + rand()%64) % DEGREES] * SHARD_EXP_VEL;
+ vel = SHARD_MIN_VEL + (SHARD_MAX_VEL*rand()/(RAND_MAX+SHARD_MIN_VEL));
+- ptl->vel[i].x += vel * sin_lookup[d] * 10;
+- ptl->vel[i].y += vel * -cos_lookup[d] * 10;
++ ptl->vel[i].x += vel * sin_lookup[d % DEGREES] * 10;
++ ptl->vel[i].y += vel * -cos_lookup[d % DEGREES] * 10;
+ }
+
+ ptl = particles_new(color2, PTL_TOP, num_sh2);
+@@ -357,8 +357,8 @@
+ ptl->vel[i].x = sin_lookup[rand()%256] * SHARD_EXP_VEL;
+ ptl->vel[i].y = -cos_lookup[rand()%256] * SHARD_EXP_VEL;
+ vel = SHARD_MIN_VEL + (SHARD_MAX_VEL*rand()/(RAND_MAX+SHARD_MIN_VEL));
+- ptl->vel[i].x += vel * sin_lookup[d] * 20;
+- ptl->vel[i].y += vel * -cos_lookup[d] * 20;
++ ptl->vel[i].x += vel * sin_lookup[d % DEGREES] * 20;
++ ptl->vel[i].y += vel * -cos_lookup[d % DEGREES] * 20;
+ }
+
+ /* "Extra" particles (ie bullet holes) */
diff --git a/games-arcade/xtux/metadata.xml b/games-arcade/xtux/metadata.xml
new file mode 100644
index 000000000000..951624d07101
--- /dev/null
+++ b/games-arcade/xtux/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">xtux</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/xtux/xtux-20030306.ebuild b/games-arcade/xtux/xtux-20030306.ebuild
new file mode 100644
index 000000000000..2a474c3bb985
--- /dev/null
+++ b/games-arcade/xtux/xtux-20030306.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Multiplayer Gauntlet-style arcade game"
+HOMEPAGE="http://xtux.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xtux/xtux-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="x11-libs/libXpm"
+RDPENED="${DEPEND}"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ find data/ -type d -name .xvpics -exec rm -rf \{\} +
+ sed -i \
+ -e "s:-g -Wall -O2:${CFLAGS}:" \
+ src/{client,common,server}/Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:./tux_serv:tux_serv:" \
+ src/client/menu.c \
+ || die "sed failed"
+ epatch "${FILESDIR}/${P}-particles.patch" \
+ "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ # Not parallel-make friendly (bug #247332)
+ emake DATADIR="${GAMES_DATADIR}/xtux/data" common
+ emake DATADIR="${GAMES_DATADIR}/xtux/data" ggz
+ emake DATADIR="${GAMES_DATADIR}/xtux/data" server
+ emake DATADIR="${GAMES_DATADIR}/xtux/data" client
+}
+
+src_install () {
+ dogamesbin xtux tux_serv
+ insinto "${GAMES_DATADIR}/xtux"
+ doins -r data/
+ dodoc AUTHORS CHANGELOG README README.GGZ doc/*
+ newicon data/images/icon.xpm ${PN}.xpm
+ make_desktop_entry xtux "Xtux"
+ prepgamesdirs
+}