summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-21 21:38:11 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-21 21:38:11 +0100
commit94d1d63f0c6234165b650f748b03af9f34238ac9 (patch)
tree0ccc54e2743e41292964138b69faaeb943a5f7c5 /games-arcade
parentgames-emulation/advancemame: Add upstream patch for -fno-common (diff)
downloadgentoo-94d1d63f0c6234165b650f748b03af9f34238ac9.tar.gz
gentoo-94d1d63f0c6234165b650f748b03af9f34238ac9.tar.bz2
gentoo-94d1d63f0c6234165b650f748b03af9f34238ac9.zip
games-arcade/primateplunge: Port to EAPI 7
Closes: https://bugs.gentoo.org/724414 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/primateplunge/files/primateplunge-1.1-fno-common.patch11
-rw-r--r--games-arcade/primateplunge/primateplunge-1.1-r2.ebuild20
2 files changed, 24 insertions, 7 deletions
diff --git a/games-arcade/primateplunge/files/primateplunge-1.1-fno-common.patch b/games-arcade/primateplunge/files/primateplunge-1.1-fno-common.patch
new file mode 100644
index 000000000000..7905b0372e72
--- /dev/null
+++ b/games-arcade/primateplunge/files/primateplunge-1.1-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/src/game.h
++++ b/src/game.h
+@@ -125,7 +125,7 @@
+
+
+ /* Glabals in main.c */
+-SDL_Surface *mainScreen;
++extern SDL_Surface *mainScreen;
+
+ /* Globals in game.c */
+ extern world* currentWorld;
diff --git a/games-arcade/primateplunge/primateplunge-1.1-r2.ebuild b/games-arcade/primateplunge/primateplunge-1.1-r2.ebuild
index 4023588bfee4..b14ba0d459b0 100644
--- a/games-arcade/primateplunge/primateplunge-1.1-r2.ebuild
+++ b/games-arcade/primateplunge/primateplunge-1.1-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit autotools desktop
DESCRIPTION="Help poor Monkey navigate his way down through treacherous areas"
@@ -11,22 +12,27 @@ SRC_URI="https://www.aelius.com/${PN}/${P}.tar.gz"
LICENSE="Primate-Plunge"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RESTRICT="mirror bindist" #465850
-DEPEND="media-libs/libsdl[sound,video]
+DEPEND="
+ media-libs/libsdl[sound,video]
media-libs/sdl-mixer"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-AC_SUBST.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
src_prepare() {
default
- eapply "${FILESDIR}"/${P}-AC_SUBST.patch
eautoreconf
}
src_install() {
default
dodoc TIPS
- newicon graphics/idle.bmp ${PN}.bmp
- make_desktop_entry ${PN} "Primate Plunge" /usr/share/pixmaps/${PN}.bmp
+
+ newicon graphics/idle.bmp primateplunge.bmp
+ make_desktop_entry primateplunge "Primate Plunge" /usr/share/pixmaps/primateplunge.bmp
}