summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-08-02 20:22:12 -0500
committerJames Le Cuirot <chewi@gentoo.org>2018-08-27 22:23:02 +0100
commitaf520e35560e761d31f6988e8a28b65cefcb291e (patch)
treee22bed4e7d4f93c017b9e57639d6bfa2b66ee128 /games-arcade
parentgames-arcade/opentyrian: eutils->desktop (diff)
downloadgentoo-af520e35560e761d31f6988e8a28b65cefcb291e.tar.gz
gentoo-af520e35560e761d31f6988e8a28b65cefcb291e.tar.bz2
gentoo-af520e35560e761d31f6988e8a28b65cefcb291e.zip
games-arcade/opentyrian: add gnome2-utils
Needed for gnome2_icon_cache_update in pkg_postinst and pkg_postrm. Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild b/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
index f1b0678fb4ea..fc82628bc521 100644
--- a/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
+++ b/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit desktop
+inherit desktop gnome2-utils
DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
HOMEPAGE="https://bitbucket.org/opentyrian/opentyrian/wiki/Home"
@@ -47,3 +47,11 @@ src_install() {
rm *.exe dpmi16bi.ovl loudness.awe || die "Failed to remove win32 binaries"
doins * || die "Failed to install game data"
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}