summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/cgoban
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/cgoban')
-rw-r--r--games-board/cgoban/Manifest1
-rw-r--r--games-board/cgoban/cgoban-1.9.14.ebuild39
-rw-r--r--games-board/cgoban/files/cgoban-1.9.14-cflags.patch35
-rw-r--r--games-board/cgoban/metadata.xml8
4 files changed, 83 insertions, 0 deletions
diff --git a/games-board/cgoban/Manifest b/games-board/cgoban/Manifest
new file mode 100644
index 000000000000..931b46d3a48c
--- /dev/null
+++ b/games-board/cgoban/Manifest
@@ -0,0 +1 @@
+DIST cgoban-1.9.14.tar.gz 417691 SHA256 3b8a6fc0e989bf977fcd9a65a367aa18e34c6e25800e78dd8f0063fa549c9b62 SHA512 0a471845dbfb3029c2371ba91375aa19ca23591f355452d87eeef2ed56e948a60aedb21923658e74923f16b40ce00f5d74f40f44facf93695d20615b874b354c WHIRLPOOL 6df36f1aba50e109683b283b21573200902371a449e4e4975c3d596b3c488d3a48f15a7754ec676bf0aff6bcedf814cdb26065e649bf12ffc61fae26716a3e45
diff --git a/games-board/cgoban/cgoban-1.9.14.ebuild b/games-board/cgoban/cgoban-1.9.14.ebuild
new file mode 100644
index 000000000000..4f1fdd4a2efb
--- /dev/null
+++ b/games-board/cgoban/cgoban-1.9.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools games
+
+DESCRIPTION="A Go-frontend"
+HOMEPAGE="http://cgoban1.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cgoban1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ cp cgoban_icon.png ${PN}.png || die
+ mv configure.{in,ac} || die
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon ${PN}.png
+ make_desktop_entry cgoban Cgoban
+ prepgamesdirs
+}
diff --git a/games-board/cgoban/files/cgoban-1.9.14-cflags.patch b/games-board/cgoban/files/cgoban-1.9.14-cflags.patch
new file mode 100644
index 000000000000..7228b4803c95
--- /dev/null
+++ b/games-board/cgoban/files/cgoban-1.9.14-cflags.patch
@@ -0,0 +1,35 @@
+--- configure.ac.old 2012-09-03 18:34:15.358122626 +0200
++++ configure.ac 2012-09-03 18:35:30.279156534 +0200
+@@ -1,8 +1,9 @@
+ #for autoconf 2.1x start configure script with next three lines
+
+ AC_PREREQ(2.13)
+-AC_INIT(src/cgoban.c)
+-AM_INIT_AUTOMAKE(cgoban, 1.9.14)
++AC_INIT([cgoban], [1.9.14])
++AC_CONFIG_SRCDIR([src/cgoban.c])
++AM_INIT_AUTOMAKE([no-define])
+
+ #for autoconf 2.5x start configure script with next four lines
+ # AC_PREREQ(2.50)
+--- configure.ac.old 2012-09-03 20:17:48.037549487 +0200
++++ configure.ac 2012-09-03 20:18:00.267371203 +0200
+@@ -146,7 +146,7 @@
+ ######################################################################
+
+ export VERSION
+-AC_DEFINE_UNQUOTED(VERSION,$VERSION)
++AC_DEFINE_UNQUOTED(VERSION,["$VERSION"])
+ AC_PREFIX_DEFAULT(/usr/games)
+
+ dayNum=`echo $date | awk '{ print $1 }'`
+--- configure.ac.old 2012-09-03 20:23:29.174470309 +0200
++++ configure.ac 2012-09-03 20:23:51.895996955 +0200
+@@ -169,7 +169,6 @@
+ AC_MINIX
+ AC_PROG_CPP
+ AC_EXEEXT
+-WMS_GET_CFLAGS
+
+ AM_CONFIG_HEADER(configure.h)
+ AC_SUBST(LIBS)dnl
diff --git a/games-board/cgoban/metadata.xml b/games-board/cgoban/metadata.xml
new file mode 100644
index 000000000000..e3ef098ef564
--- /dev/null
+++ b/games-board/cgoban/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">cgoban1</remote-id>
+ </upstream>
+</pkgmetadata>