summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaymond Jennings <shentino@gmail.com>2018-11-01 12:38:03 -0700
committerJames Le Cuirot <chewi@gentoo.org>2018-11-10 21:12:33 +0000
commite647fa5696961477d3e221ba17ed5673195f8701 (patch)
tree55e693906ab56ec06bc42765f0b8457214165312 /games-emulation
parentmedia-libs/libifp: Drop old (diff)
downloadgentoo-e647fa5696961477d3e221ba17ed5673195f8701.tar.gz
gentoo-e647fa5696961477d3e221ba17ed5673195f8701.tar.bz2
gentoo-e647fa5696961477d3e221ba17ed5673195f8701.zip
games-emulation/stella: Version bump to 5.1.3
* Update SRC_URI and HOMEPAGE * Amend DESCRIPTION * Move DOCS and HTML_DOCS to global variables and make them arrays * Remove redundant default gnome2 icon calls * Clean up ebuild formatting * Update icon cache on install and uninstall Signed-off-by: Raymond Jennings <shentino@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10310
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/Manifest1
-rw-r--r--games-emulation/stella/stella-5.1.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index f3e43e672a74..1b0bc1a6ea03 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1 +1,2 @@
DIST stella-4.7.2-src.tar.xz 1715332 BLAKE2B 7b397a4e662f8db247a67ddedb314c9b11ee4e99d55768b1cd8e2587b452fab9c5d45c840bf1577833712a2c96d42985d39437d1fac16e93c35762e015ddf445 SHA512 dcfaba9b554ab08c9ba79c8e95551bc688fae4ab0ab368df11c05f3dc7c9431d32068d5dd658ec4d1aa8cb826c7205fc4f301145a149d32369833409992455e2
+DIST stella-5.1.3-src.tar.xz 1828448 BLAKE2B 1588e4da3c21ab51d967aa3fae49b14ef5f3121e3907aa83629dbabeab5c190660ad5a53319429f721cc93560c212f530a58675b7c543c9a3fed3e395669c145 SHA512 9aaf6118c999e90e4947e490f61ccebb82ba1ebeccb29b2e4ec1226bdeef83bb36d944791d6f915522c5c6fec74a0bd17ac5ce8fcc5f369281f9cedf06a380a5
diff --git a/games-emulation/stella/stella-5.1.3.ebuild b/games-emulation/stella/stella-5.1.3.ebuild
new file mode 100644
index 000000000000..0c5791505610
--- /dev/null
+++ b/games-emulation/stella/stella-5.1.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils
+
+DESCRIPTION="Multi-platform Atari 2600 VCS Emulator"
+HOMEPAGE="https://stella-emu.github.io"
+SRC_URI="https://github.com/stella-emu/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick"
+
+RDEPEND="
+ media-libs/libsdl2[joystick?,opengl,video]
+ media-libs/libpng:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+DOCS=(Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt)
+HTML_DOCS=(docs/.)
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
+ Makefile || die
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="/usr/bin" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="/usr/share" \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ default
+ local i
+
+ for i in 16 22 24 32 48 64 128 ; do
+ newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
+ done
+ domenu src/unix/stella.desktop
+ einstalldocs
+}
+
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }