summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/quake1-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/quake1-data')
-rw-r--r--games-fps/quake1-data/metadata.xml5
-rw-r--r--games-fps/quake1-data/quake1-data-2.40.ebuild69
2 files changed, 74 insertions, 0 deletions
diff --git a/games-fps/quake1-data/metadata.xml b/games-fps/quake1-data/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/quake1-data/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/quake1-data/quake1-data-2.40.ebuild b/games-fps/quake1-data/quake1-data-2.40.ebuild
new file mode 100644
index 000000000000..1e7eff5d247b
--- /dev/null
+++ b/games-fps/quake1-data/quake1-data-2.40.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: if installing off of the 1.01 cd, need to fetch the
+# quake shareware and use that pak0
+# http://linux.omnipotent.net/article.php?article_id=11287
+# ftp://ftp.cdrom.com/pub/idgames/idstuff/quake/quake106.zip
+
+EAPI=2
+inherit eutils cdrom games
+
+DESCRIPTION="iD Software's Quake 1 ... the data files"
+HOMEPAGE="http://www.idsoftware.com/games/quake/quake/"
+SRC_URI=""
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86"
+IUSE=""
+
+DEPEND="app-arch/lha"
+RDEPEND=""
+
+S=${WORKDIR}
+
+pkg_setup() {
+ games_pkg_setup
+
+ if has_version games-fps/quake1-demodata && \
+ ! has_version "games-fps/quake1-demodata[symlink]" ; then
+ eerror "The symlink for the demo data conflicts with the cdinstall data"
+ die "Unmerge games-fps/quake1-demodata to remove the conflict"
+ fi
+}
+
+src_unpack() {
+ export CDROM_NAME_SET=("Existing Install" "Quake CD (1.01)" "Ultimate Quake Collection" "Quake CD (newer)")
+ cdrom_get_cds id1:q101_int.1:Setup/ID1:resource.1
+ if [[ ${CDROM_SET} == "1" ]] ; then
+ echo ">>> Unpacking q101_int.lha to ${PWD}"
+ cat "${CDROM_ROOT}"/q101_int.1 "${CDROM_ROOT}"/q101_int.2 > \
+ "${S}"/q101_int.exe
+ lha xqf "${S}"/q101_int.exe || die "failure unpacking q101_int.exe"
+ rm -f q101_int.exe
+ elif [[ ${CDROM_SET} == "3" ]] ; then
+ echo ">>> Unpacking resource.1 to ${PWD}"
+ lha xqf "${CDROM_ROOT}"/resource.1 || die "failure unpacking resource.1"
+ fi
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/quake1/id1
+ case ${CDROM_SET} in
+ 0) doins "${CDROM_ROOT}"/id1/* || die "doins pak files"
+ dodoc "${CDROM_ROOT}"/*.txt
+ ;;
+ 1|3)doins id1/* || die "doins pak files"
+ dodoc *.txt
+ ;;
+ 2) newins "${CDROM_ROOT}"/Setup/ID1/PAK0.PAK pak0.pak \
+ || die "ins pak0.pak failed"
+ newins "${CDROM_ROOT}"/Setup/ID1/PAK1.PAK pak1.pak \
+ || die "ins pak1.pak failed"
+ dodoc "${CDROM_ROOT}"/Docs/*
+ ;;
+ esac
+ prepgamesdirs
+}