summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 01:32:46 +0000
committerSam James <sam@gentoo.org>2021-04-07 01:57:37 +0000
commitc2015ef74c53eb06df23e74a2b6387b0df3d2300 (patch)
treeb0e779c3fbe78969e00b77edac9119837ba5553c /games-fps/quake2-data/quake2-data-3.20.ebuild
parentgames-fps/quake2-demodata: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-c2015ef74c53eb06df23e74a2b6387b0df3d2300.tar.gz
gentoo-c2015ef74c53eb06df23e74a2b6387b0df3d2300.tar.bz2
gentoo-c2015ef74c53eb06df23e74a2b6387b0df3d2300.zip
games-fps/quake2-data: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps/quake2-data/quake2-data-3.20.ebuild')
-rw-r--r--games-fps/quake2-data/quake2-data-3.20.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/games-fps/quake2-data/quake2-data-3.20.ebuild b/games-fps/quake2-data/quake2-data-3.20.ebuild
deleted file mode 100644
index d7eda8747829..000000000000
--- a/games-fps/quake2-data/quake2-data-3.20.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit unpacker eutils cdrom games
-
-DESCRIPTION="iD Software's Quake 2 ... the data files"
-HOMEPAGE="https://www.idsoftware.com/"
-SRC_URI="mirror://idsoftware/quake2/q2-${PV}-x86-full-ctf.exe"
-
-LICENSE="Q2EULA"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~x86"
-IUSE="videos"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-S=${WORKDIR}
-
-pkg_setup() {
- games_pkg_setup
- if has_version "games-fps/quake2-demodata[symlink]" ; then
- eerror "The symlink for the demo data conflicts with the cdinstall data"
- die "Unmerge games-fps/quake2-demodata to remove the conflict"
- fi
-}
-
-src_unpack() {
- export CDROM_NAME_SET=("Existing Install" "Ultimate Quake Edition" "Quake2 CD" "Quake4 Bonus DVD")
- cdrom_get_cds baseq2:Install/patch:Install:Movies
- # The .exe is just a self-extracting .zip
- unpack_zip ${A}
-}
-
-src_install() {
- dodoc DOCS/* 3.20_Changes.txt
- newdoc ctf/readme.txt ctf-readme.txt
- case ${CDROM_SET} in
- 0) dohtml -r "${CDROM_ROOT}"/Install/DOCS/quake2_manual/* ;;
- 1) dohtml -r "${CDROM_ROOT}"/Install/Docs/quake2_manual/* ;;
- 2) dohtml -r "${CDROM_ROOT}"/Install/DOCS/quake2_manual/* ;;
- 3) dodoc "${CDROM_ROOT}"/Docs/* ;;
- esac
-
- local baseq2_cdpath
- case ${CDROM_SET} in
- 0) baseq2_cdpath=${CDROM_ROOT}/baseq2;;
- 1) baseq2_cdpath=${CDROM_ROOT}/Install/Data/baseq2;;
- 2) baseq2_cdpath=${CDROM_ROOT}/Install/Data/baseq2;;
- 3) baseq2_cdpath=${CDROM_ROOT}/setup/Data/baseq2;;
- esac
-
- dodir "${GAMES_DATADIR}"/quake2/baseq2
-
- if use videos ; then
- insinto "${GAMES_DATADIR}"/quake2/baseq2/video
- doins "${baseq2_cdpath}"/video/*
- fi
-
- insinto "${GAMES_DATADIR}"/quake2/baseq2
- doins "${baseq2_cdpath}"/pak0.pak
- doins baseq2/*.pak baseq2/maps.lst
- dodir "${GAMES_DATADIR}"/quake2/baseq2/players
- cp -R "${baseq2_cdpath}"/players/* baseq2/players/* \
- "${D}/${GAMES_DATADIR}"/quake2/baseq2/players/ || die
-
- for mod in ctf rogue xatrix ; do
- if [[ -d ${baseq2_cdpath}/../${mod} ]] ; then
- if use videos && [[ -d ${baseq2_cdpath}/../${mod}/video ]] ; then
- insinto "${GAMES_DATADIR}"/quake2/${mod}/video
- doins "${baseq2_cdpath}"/../${mod}/video/* 2>/dev/null
- fi
- if [[ -n $(ls "${baseq2_cdpath}"/../${mod}/*.pak 2>/dev/null) ]] ; then
- insinto "${GAMES_DATADIR}"/quake2/${mod}
- doins "${baseq2_cdpath}"/../${mod}/*.pak
- fi
- fi
- done
-
- insinto "${GAMES_DATADIR}"/quake2/ctf
- doins ctf/*.{cfg,ico,pak}
-
- prepgamesdirs
-}