summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/neverball
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/neverball')
-rw-r--r--games-puzzle/neverball/Manifest2
-rw-r--r--games-puzzle/neverball/files/neverball-1.5.4-libpng.patch21
-rw-r--r--games-puzzle/neverball/files/neverball-1.5.4-lm.patch28
-rw-r--r--games-puzzle/neverball/files/neverball-1.5.4-underlink.patch11
-rw-r--r--games-puzzle/neverball/metadata.xml5
-rw-r--r--games-puzzle/neverball/neverball-1.5.4.ebuild84
-rw-r--r--games-puzzle/neverball/neverball-1.6.0.ebuild100
7 files changed, 251 insertions, 0 deletions
diff --git a/games-puzzle/neverball/Manifest b/games-puzzle/neverball/Manifest
new file mode 100644
index 000000000000..9160adcd8d42
--- /dev/null
+++ b/games-puzzle/neverball/Manifest
@@ -0,0 +1,2 @@
+DIST neverball-1.5.4.tar.gz 26767623 SHA256 ea31ca9f6eec70c8e66eaa20d7ce9e48295fdb077313b97637c503b16b7b0da6 SHA512 ffc0473ea3882edb84f190aa696c2e5fa1a38ea50f73bc144a3b694fd80c71a8d9936aa34f8bbd096523493849d428928a6efd2650c6da4c9962e0355d3cb9c2 WHIRLPOOL c0e6731ee28eb8ac987d5ca98ecbd93fb7d091060e2da51c6fe69043f05fe7d5f8179e62183f946e40b2f734a8041ab35ae1fdd4024e5ff6e25ab8633853e1f4
+DIST neverball-1.6.0.tar.gz 37772911 SHA256 73fe63cca4f96e2d355480d03bc0b2904e83a0abdf65fe8c52db5cc3cca88fa0 SHA512 174d05308aee3a5e693782c54dd389439752b3597f28193771041d30f6c4236a5d055b2fcca9460b1005e9f000ddb3cbc01b86ea15c2abbf6e5a7996e836f787 WHIRLPOOL 017ac177b3557e0473d94288c0645ce7e6ddf15cdfbddb6798b22a6341d9864532d0d2263ed785bbed8c1bf5c9e4acbc6e31effdcc06b299a8fcf7c1fa60e514
diff --git a/games-puzzle/neverball/files/neverball-1.5.4-libpng.patch b/games-puzzle/neverball/files/neverball-1.5.4-libpng.patch
new file mode 100644
index 000000000000..d7b224673186
--- /dev/null
+++ b/games-puzzle/neverball/files/neverball-1.5.4-libpng.patch
@@ -0,0 +1,21 @@
+Index: neverball-1.5.4/share/base_image.c
+===================================================================
+--- neverball-1.5.4.orig/share/base_image.c
++++ neverball-1.5.4/share/base_image.c
+@@ -15,6 +15,7 @@
+ #include <png.h>
+ #include <jpeglib.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <assert.h>
+
+ #include "glext.h"
+@@ -94,7 +95,7 @@ static void *image_load_png(const char *
+ default: longjmp(png_jmpbuf(readp), -1);
+ }
+
+- if (!(bytep = png_malloc(readp, h * png_sizeof(png_bytep))))
++ if (!(bytep = png_malloc(readp, h * sizeof(png_bytep))))
+ longjmp(png_jmpbuf(readp), -1);
+
+ /* Allocate the final pixel buffer and read pixels there. */
diff --git a/games-puzzle/neverball/files/neverball-1.5.4-lm.patch b/games-puzzle/neverball/files/neverball-1.5.4-lm.patch
new file mode 100644
index 000000000000..4245e28fe2f2
--- /dev/null
+++ b/games-puzzle/neverball/files/neverball-1.5.4-lm.patch
@@ -0,0 +1,28 @@
+Fix link faiure against -lm
+
+x86_64-pc-linux-gnu-gcc -Wall -ansi -pedantic -march=core2 -O2 -pipe -ggdb -o neverball-mapc share/vec3.o share/base_image.o share/solid.o share/binary.o share/base_config.o share/common.o share/fs.o share/fs_png.o share/fs_jpg.o share/dir.o share/array.o share/mapc.o -Wl,-O1 -Wl,--as-needed -ljpeg -lpng15 -lphysfs
+/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.2/../../../../x86_64-pc-linux-gnu/bin/ld: share/mapc.o: undefined reference to symbol 'acosf@@GLIBC_2.2.5'
+/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.2/../../../../x86_64-pc-linux-gnu/bin/ld: note: 'acosf@@GLIBC_2.2.5' is defined in DSO /lib64/libm.so.6 so try adding it to the linker command line
+
+Gentoo-bug: http://bugs.gentoo.org/464014
+diff --git a/Makefile b/Makefile
+index 62a87e9..1816707 100644
+--- a/Makefile
++++ b/Makefile
+@@ -132,6 +132,7 @@ ifdef DARWIN
+ endif
+
+ BASE_LIBS := -ljpeg $(PNG_LIBS) $(FS_LIBS)
++MAPC_LIBS := -lm # only acosf user
+
+ ifdef DARWIN
+ BASE_LIBS += -L/opt/local/lib
+@@ -318,7 +319,7 @@ $(PUTT_TARG) : $(PUTT_OBJS)
+ $(CC) $(ALL_CFLAGS) -o $(PUTT_TARG) $(PUTT_OBJS) $(LDFLAGS) $(ALL_LIBS)
+
+ $(MAPC_TARG) : $(MAPC_OBJS)
+- $(CC) $(ALL_CFLAGS) -o $(MAPC_TARG) $(MAPC_OBJS) $(LDFLAGS) $(BASE_LIBS)
++ $(CC) $(ALL_CFLAGS) -o $(MAPC_TARG) $(MAPC_OBJS) $(LDFLAGS) $(MAPC_LIBS) $(BASE_LIBS)
+
+ # Work around some extremely helpful sdl-config scripts.
+
diff --git a/games-puzzle/neverball/files/neverball-1.5.4-underlink.patch b/games-puzzle/neverball/files/neverball-1.5.4-underlink.patch
new file mode 100644
index 000000000000..c6f27cc2bf8a
--- /dev/null
+++ b/games-puzzle/neverball/files/neverball-1.5.4-underlink.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2011-06-22 06:30:52.441788160 +0200
++++ Makefile 2011-06-22 06:31:59.754087534 +0200
+@@ -138,7 +138,7 @@
+ endif
+
+ ALL_LIBS := $(SDL_LIBS) $(BASE_LIBS) $(TILT_LIBS) $(INTL_LIBS) -lSDL_ttf \
+- -lvorbisfile $(OGL_LIBS)
++ -lvorbisfile $(OGL_LIBS) -lX11
+
+ #------------------------------------------------------------------------------
+
diff --git a/games-puzzle/neverball/metadata.xml b/games-puzzle/neverball/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/neverball/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/neverball/neverball-1.5.4.ebuild b/games-puzzle/neverball/neverball-1.5.4.ebuild
new file mode 100644
index 000000000000..4359a87c730a
--- /dev/null
+++ b/games-puzzle/neverball/neverball-1.5.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Clone of Super Monkey Ball using SDL/OpenGL"
+HOMEPAGE="http://icculus.org/neverball/"
+SRC_URI="http://icculus.org/neverball/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+RESTRICT="test"
+
+RDEPEND="media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/sdl-ttf
+ media-libs/libpng:0
+ virtual/jpeg
+ media-libs/libvorbis
+ virtual/opengl
+ dev-games/physfs
+ media-fonts/dejavu
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e 's:mapc:neverball-mapc:g' \
+ -e 's:MAPC:NEVERBALL-MAPC:g' \
+ -e '1 s/ 1 / 6 /' \
+ dist/mapc.1 \
+ || die "sed failed"
+ sed -i \
+ -e 's:-O2:$(E_CFLAGS):' \
+ -e "/^MAPC_TARG/s/mapc/${PN}-mapc/" \
+ Makefile \
+ || die "sed failed"
+ epatch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-libpng.patch \
+ "${FILESDIR}"/${P}-lm.patch
+}
+
+src_compile() {
+ emake \
+ ENABLE_NLS=$(use nls && echo 1 || echo 0) \
+ E_CFLAGS="${CFLAGS}" \
+ LOCALEDIR=/usr/share/locale \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN}-mapc neverball neverputt || die
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/* || die
+ rm -f "${D}${GAMES_DATADIR}/${PN}"/ttf/DejaVuSans-Bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf \
+ "${GAMES_DATADIR}/${PN}"/ttf/DejaVuSans-Bold.ttf || die
+ if [[ -d locale ]] ; then
+ insinto /usr/share
+ doins -r locale || die
+ fi
+ dodoc CHANGES README || die
+
+ newicon dist/neverball_512.png neverball.png || die
+ newicon dist/neverputt_512.png neverputt.png || die
+ doman dist/*.6 || die
+ newman dist/mapc.1 neverball-mapc.6 || die
+ make_desktop_entry neverball Neverball || die
+ make_desktop_entry neverputt Neverputt neverputt || die
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "${P} will overwrite existing high-score files, so back them up if"
+ elog "you want to preserve your old scores and progress."
+}
diff --git a/games-puzzle/neverball/neverball-1.6.0.ebuild b/games-puzzle/neverball/neverball-1.6.0.ebuild
new file mode 100644
index 000000000000..73ca285c870e
--- /dev/null
+++ b/games-puzzle/neverball/neverball-1.6.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Clone of Super Monkey Ball using SDL/OpenGL"
+HOMEPAGE="http://neverball.org/"
+SRC_URI="http://neverball.org/${P}.tar.gz"
+
+LICENSE="GPL-2+ IJG"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+RESTRICT="test"
+
+RDEPEND="media-libs/libsdl2[sound,joystick,opengl,video]
+ media-libs/sdl2-ttf
+ media-libs/libpng:0
+ virtual/jpeg
+ media-libs/libvorbis
+ virtual/opengl
+ dev-games/physfs
+ media-fonts/dejavu
+ media-fonts/wqy-microhei
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e 's:mapc:neverball-mapc:g' \
+ -e 's:MAPC:NEVERBALL-MAPC:g' \
+ -e '1 s/ 1 / 6 /' \
+ dist/mapc.1 || die
+ sed -i \
+ -e '/CFLAGS.*O2/s:-O2:$(E_CFLAGS):' \
+ -e '/CXXFLAGS.*O2/s:-O2:$(E_CXXFLAGS):' \
+ -e "/^MAPC_TARG/s/mapc/${PN}-mapc/" \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ ENABLE_NLS=$(use nls && echo 1 || echo 0) \
+ E_CFLAGS="${CFLAGS}" \
+ E_CXXFLAGS="${CXXFLAGS}" \
+ LOCALEDIR=/usr/share/locale \
+ DATADIR="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ local font
+
+ dogamesbin ${PN}-mapc neverball neverputt
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/*
+ for font in DejaVuSans-Bold.ttf wqy-microhei.ttc
+ do
+ rm -f "${D}${GAMES_DATADIR}/${PN}"/ttf/${font}
+ dosym /usr/share/fonts/*/${font} \
+ "${GAMES_DATADIR}/${PN}"/ttf/${font}
+ done
+ if [[ -d locale ]] ; then
+ insinto /usr/share
+ doins -r locale
+ fi
+ dodoc doc/{authors.txt,manual.txt,release-notes.md} README.md
+
+ local res name
+ for name in ball putt; do
+ for res in 16 32 64 128 256; do
+ newicon -s ${res} dist/never${name}_${res}.png never${name}.png
+ done
+ done
+
+ doman dist/*.6
+ newman dist/mapc.1 neverball-mapc.6
+ make_desktop_entry neverball Neverball
+ make_desktop_entry neverputt Neverputt neverputt
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ games_pkg_postinst
+ elog "${P} will overwrite existing high-score files, so back them up if"
+ elog "you want to preserve your old scores and progress."
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}