summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/gwiz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/gwiz')
-rw-r--r--games-rpg/gwiz/Manifest1
-rw-r--r--games-rpg/gwiz/files/gwiz-0.8-buffer.patch23
-rw-r--r--games-rpg/gwiz/gwiz-0.8.ebuild31
-rw-r--r--games-rpg/gwiz/metadata.xml5
4 files changed, 60 insertions, 0 deletions
diff --git a/games-rpg/gwiz/Manifest b/games-rpg/gwiz/Manifest
new file mode 100644
index 000000000000..5da8ff0543d2
--- /dev/null
+++ b/games-rpg/gwiz/Manifest
@@ -0,0 +1 @@
+DIST gwiz-0.8.tar.bz2 1141667 SHA256 8b19a5523460068a0e3ed4d9b7ec51de0dfb28418d75ccb00afcd4e13eae4f08 SHA512 3c18cc7e905dd87eab7dbf332b985600bbcc8c2992fbc79d992fb0f00c3095c502f416166f0e3320f18b9e011c26675c42e79375f44225b61aba415509837f20 WHIRLPOOL 2831b664a7b2083a477e80873f31fc6b3d07c60f6a9b1ec27068b32774c69fac03c0e5bcaf2bbf02bd03e8fcfa1c401d5036bbc43309dd4d7c8e454c57af66dd
diff --git a/games-rpg/gwiz/files/gwiz-0.8-buffer.patch b/games-rpg/gwiz/files/gwiz-0.8-buffer.patch
new file mode 100644
index 000000000000..7c9eb02cf503
--- /dev/null
+++ b/games-rpg/gwiz/files/gwiz-0.8-buffer.patch
@@ -0,0 +1,23 @@
+--- src/equip.c.orig
++++ src/equip.c
+@@ -120,7 +120,7 @@
+ return (i);
+
+ /* if we get this far, there are no equippable items before the current */
+- for (i = 8; i > offset; i--)
++ for (i = 7; i > offset; i--)
+ if (pawn->item[i].usage & USAGE_EQUIPPABLE)
+ return (i);
+ return (-1);
+--- src/shop.c.orig
++++ src/shop.c
+@@ -290,8 +290,7 @@
+
+ SDL_BlitSurface (name, NULL, area, &dest);
+
+- snprintf (price, sizeof(char)*8, "%d", pawn->item[i].sellfor);
+- price[9] = '\0';
++ snprintf (price, sizeof(price), "%d", pawn->item[i].sellfor);
+ profit = GwizRenderText (price);
+ dest.x = area->w - profit->w;
+ dest.w = profit->w;
diff --git a/games-rpg/gwiz/gwiz-0.8.ebuild b/games-rpg/gwiz/gwiz-0.8.ebuild
new file mode 100644
index 000000000000..bcdc52ddc4e6
--- /dev/null
+++ b/games-rpg/gwiz/gwiz-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="clone of old-school Wizardry(tm) games by SirTech"
+HOMEPAGE="http://icculus.org/gwiz/"
+SRC_URI="http://icculus.org/gwiz/${P}.tar.bz2"
+
+KEYWORDS="~alpha amd64 ppc x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.3[joystick,video]
+ >=media-libs/sdl-image-1.2.1-r1[png]
+ >=media-libs/sdl-ttf-2.0.4"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buffer.patch
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README doc/HOWTO-PLAY" \
+ default
+ newicon pixmaps/gwiz_icon.xpm ${PN}.xpm
+ make_desktop_entry gwiz Gwiz
+}
diff --git a/games-rpg/gwiz/metadata.xml b/games-rpg/gwiz/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-rpg/gwiz/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>