summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/wastesedge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/wastesedge')
-rw-r--r--games-rpg/wastesedge/Manifest1
-rw-r--r--games-rpg/wastesedge/metadata.xml5
-rw-r--r--games-rpg/wastesedge/wastesedge-0.3.5.ebuild41
3 files changed, 47 insertions, 0 deletions
diff --git a/games-rpg/wastesedge/Manifest b/games-rpg/wastesedge/Manifest
new file mode 100644
index 000000000000..3b8b8134a438
--- /dev/null
+++ b/games-rpg/wastesedge/Manifest
@@ -0,0 +1 @@
+DIST wastesedge-src-0.3.5.tar.gz 10749912 SHA256 f872a2dc89ca454523f5b55c7fc8b29986dae8bc72f52647a6e1dab3f2a30674 SHA512 d4c77eb1bde2c28002e4f56a6bfa5f816ea53de7061b5e60635f15c670ff45c3a18e3316b92007f74033a62538503f14b67e1175cf22c718c22ca1021dc7af3b WHIRLPOOL 38695ec20bb171a47af8d691e52c07f4eb4331798b790bf4d93cf56bcbb3846a91daa88fee9d9e659ef8f2ccb2e54065e988ceb7683fb24656e4c24ff50b7c7c
diff --git a/games-rpg/wastesedge/metadata.xml b/games-rpg/wastesedge/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-rpg/wastesedge/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-rpg/wastesedge/wastesedge-0.3.5.ebuild b/games-rpg/wastesedge/wastesedge-0.3.5.ebuild
new file mode 100644
index 000000000000..06e9c591f1cb
--- /dev/null
+++ b/games-rpg/wastesedge/wastesedge-0.3.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+DESCRIPTION="role playing game to showcase the adonthell engine"
+HOMEPAGE="http://adonthell.linuxgames.com/"
+SRC_URI="http://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+RESTRICT="userpriv"
+
+RDEPEND="${PYTHON_DEPS}
+ >=games-rpg/adonthell-0.3.5-r1[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_configure(){
+ egamesconf \
+ $(use_enable nls) \
+ --with-adonthell-binary="${GAMES_BINDIR}/adonthell"
+}
+
+src_install(){
+ emake DESTDIR="${D}" pixmapdir=/usr/share/pixmaps install
+ dodoc AUTHORS ChangeLog NEWS PLAYING README
+ make_desktop_entry adonthell-wastesedge "Waste's Edge" wastesedge_32x32
+ prepgamesdirs
+}