summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-server/nwn-ded
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-server/nwn-ded')
-rw-r--r--games-server/nwn-ded/Manifest2
-rw-r--r--games-server/nwn-ded/metadata.xml5
-rw-r--r--games-server/nwn-ded/nwn-ded-1.69.ebuild71
3 files changed, 78 insertions, 0 deletions
diff --git a/games-server/nwn-ded/Manifest b/games-server/nwn-ded/Manifest
new file mode 100644
index 000000000000..aecc9e4c415b
--- /dev/null
+++ b/games-server/nwn-ded/Manifest
@@ -0,0 +1,2 @@
+DIST NWNDedicatedServer1.69.zip 606293816 SHA256 9df63ea1bf24b43be2c7568a1379cb7197fb591b0c0454ec2d20cec96234a45c SHA512 0f91ab8d03d040389d9ad7ccc7d50079057d62d542fecfb2164a726511718ba982f7b2f9878bc1143f2c61b3ef7ab8f92e5e4007b515ad6aff51216c5b602ffd WHIRLPOOL 2f309f42a01c4fc01f600cb3d23e2e2c82e5ad42462e695cc56a90a59ab220bb6324a4aef9714567d8fdc9393624d63b310ff2fe225c49151932aa16d26f110a
+DIST NWNEnglish1.69dialog.zip 3200987 SHA256 357fd4c312d7598e9f563c61918f78c2235bd19acff8ac1b2d19140972828d66 SHA512 8c3214a3bcf137ea3b4b59d89055b7e22d15b8ab8d6007d81a9e70e156f8af611a8032ce5cf5c42ecd8c5af7eebe95f012a3f91723f273efa42701fd036482be WHIRLPOOL 09724f2ea25814ea98fe865207d6d7a160abfe0e582c71d2b8c649855a16b3596722525c52037f76a1cf9194053edbb19627eb16c27975646cc7247478554a1f
diff --git a/games-server/nwn-ded/metadata.xml b/games-server/nwn-ded/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-server/nwn-ded/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-server/nwn-ded/nwn-ded-1.69.ebuild b/games-server/nwn-ded/nwn-ded-1.69.ebuild
new file mode 100644
index 000000000000..c82435d20ce0
--- /dev/null
+++ b/games-server/nwn-ded/nwn-ded-1.69.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+LANGUAGES="linguas_en"
+DIALOG_URL_BASE=http://files.bioware.com/neverwinternights/dialog/
+
+DESCRIPTION="Neverwinter Nights Dedicated server"
+HOMEPAGE="http://nwn.bioware.com/downloads/standaloneserver.html"
+SRC_URI="http://files.bioware.com/neverwinternights/updates/windows/server/NWNDedicatedServer${PV}.zip
+ linguas_en? ( ${DIALOG_URL_BASE}/english/NWNEnglish${PV}dialog.zip )"
+
+LICENSE="NWN-EULA"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="${LANGUAGES}"
+RESTRICT="mirror strip"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${dir:1}/common/nwserver"
+
+src_unpack() {
+ mkdir common || die
+ cd common || die
+ unpack NWNDedicatedServer${PV}.zip
+ tar -zxf linuxdedserver${PV/./}.tar.gz || die
+ rm -f *dedserver*.{tar.gz,sit,zip} *.exe *.dll
+ cd ..
+ local currentlocale=""
+ local a
+ for a in ${A}
+ do
+ if [ -z "${a/*dialog*/}" ] ; then
+ if [ -z "${a/*English*/}" ]; then currentlocale="en"; fi
+ if [ -z "${a/*French*/}" ]; then currentlocale="fr"; fi
+ if [ -z "${a/*German*/}" ]; then currentlocale="de"; fi
+ if [ -z "${a/*Italian*/}" ]; then currentlocale="it"; fi
+ if [ -z "${a/*Spanish*/}" ]; then currentlocale="es"; fi
+ if [ -z "${a/*Japanese*/}" ]; then currentlocale="ja"; fi
+ mkdir ${currentlocale} || die
+ cd ${currentlocale}
+ cp -rfl ../common/* . || die
+ unpack "${a}"
+ cd ..
+ fi
+ done
+}
+
+src_install() {
+ dodir ${dir}
+
+ local currentlocale
+ for currentlocale in * ; do
+ if [[ ${currentlocale} != "common" ]]
+ then
+ games_make_wrapper nwserver-${currentlocale} ./nwserver "${dir}/${currentlocale}" "${dir}/${currentlocale}"
+ fi
+ done
+
+ mv * "${D}/${dir}"/ || die
+
+ prepgamesdirs
+ chmod -R g+w "${D}/${dir}"
+}