summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/crrcsim
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/crrcsim')
-rw-r--r--games-simulation/crrcsim/Manifest1
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.12-r1.ebuild60
-rw-r--r--games-simulation/crrcsim/files/crrcsim-buildsystem.patch25
-rw-r--r--games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch11
-rw-r--r--games-simulation/crrcsim/metadata.xml12
5 files changed, 109 insertions, 0 deletions
diff --git a/games-simulation/crrcsim/Manifest b/games-simulation/crrcsim/Manifest
new file mode 100644
index 000000000000..0a90e22b8274
--- /dev/null
+++ b/games-simulation/crrcsim/Manifest
@@ -0,0 +1 @@
+DIST crrcsim-0.9.12.tar.gz 7355827 SHA256 2d166aec9ff4394a0252368d4cfcac5ba4ab8a29f58f99cd1649721a8f65a3fb SHA512 53c4a530922d58ca0211a5a3171d927c9c9161139c63e73d8dbc602e0aa1c259ef0f3ba712b30a71dc357889bbf59fa76888315bdcd264e0d29307e66b70b00a WHIRLPOOL 3f177ae208e0f70b0ebdc9aa4e1e200ff73bdf656fecb67c6ffe7a8e303bae4ce8caab4c4e01e52371c42ae389574e9c821dcb5c4afb4dc32b94661add18b7ee
diff --git a/games-simulation/crrcsim/crrcsim-0.9.12-r1.ebuild b/games-simulation/crrcsim/crrcsim-0.9.12-r1.ebuild
new file mode 100644
index 000000000000..b0b44cc47800
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.12-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WANT_AUTOMAKE="1.10"
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="model-airplane flight simulation program"
+HOMEPAGE="http://sourceforge.net/projects/crrcsim/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="sci-mathematics/cgal
+ media-libs/plib
+ media-libs/libsdl[X,sound,joystick,opengl,video]
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-buildsystem.patch
+ if has_version "sci-mathematics/cgal[gmp(+)]" ; then
+ epatch "${FILESDIR}"/${PN}-cgal_gmp.patch
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --datarootdir="${EPREFIX%/}/usr/share" \
+ --datadir="${GAMES_DATADIR}" \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
+ $(use_with portaudio)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS HISTORY NEWS README
+ doicon -s 32 packages/icons/${PN}.png
+ make_desktop_entry ${PN}
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-simulation/crrcsim/files/crrcsim-buildsystem.patch b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
new file mode 100644
index 000000000000..3bc784d16bd7
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
@@ -0,0 +1,25 @@
+--- crrcsim-0.9.11/configure.ac
++++ crrcsim-0.9.11/configure.ac
+@@ -79,8 +79,12 @@
+ dnl Default is: no portaudio present
+ portaudio=0
+
++AC_ARG_WITH([portaudio], AS_HELP_STRING([--without-portaudio], [Build without portaudio library (default: test)]))
++
++AS_IF([test "x$with_portaudio" != "xno"], [
+ dnl Check for the Portaudio header file
+ AC_CHECK_HEADER([portaudio.h])
++])
+
+ if (test "x$ac_cv_header_portaudio_h" = "xyes"); then
+ dnl Check for Portaudio 18
+--- crrcsim-0.9.12/locale/Makefile.am
++++ crrcsim-0.9.12/locale/Makefile.am
+@@ -1,7 +1,5 @@
+ # Makefile.am for "/locale"
+
+-localedir = $(datadir)/locale
+-
+ nobase_locale_DATA = fr/LC_MESSAGES/crrcsim.mo \
+ de/LC_MESSAGES/crrcsim.mo \
+ it/LC_MESSAGES/crrcsim.mo
diff --git a/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
new file mode 100644
index 000000000000..10d6bff6b769
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
@@ -0,0 +1,11 @@
+--- crrcsim-0.9.11/configure.ac
++++ crrcsim-0.9.11/configure.ac
+@@ -229,7 +229,7 @@
+ has_CGAL="yes (found CGAL v3)"
+ fi
+ CGAL_CFLAGS=-frounding-math
+- CGAL_LIBS=-lCGAL
++ CGAL_LIBS="-lCGAL -lgmp"
+ AC_DEFINE([WINDDATA3D], [1], [Import code for wind data, needs CGAL, 0 to disable])
+ else
+ has_CGAL="no (CGAL not found)"
diff --git a/games-simulation/crrcsim/metadata.xml b/games-simulation/crrcsim/metadata.xml
new file mode 100644
index 000000000000..dabacf6fdea0
--- /dev/null
+++ b/games-simulation/crrcsim/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">crrcsim</remote-id>
+ </upstream>
+</pkgmetadata>