summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-12-12 17:16:01 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-12-12 17:16:15 +0100
commit2f7dd08d95c02526a7ebb25478c0d7622a8a5811 (patch)
treef283603e134210176442ce9ac095fe5b7f8f918b /games-strategy
parentmedia-sound/shnflacverify: Port to EAPI 7 (diff)
downloadgentoo-2f7dd08d95c02526a7ebb25478c0d7622a8a5811.tar.gz
gentoo-2f7dd08d95c02526a7ebb25478c0d7622a8a5811.tar.bz2
gentoo-2f7dd08d95c02526a7ebb25478c0d7622a8a5811.zip
games-strategy/0ad: Added missing header includes
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-0.0.23b_alpha.ebuild3
-rw-r--r--games-strategy/0ad/files/0ad-0.0.23b-header_includes_fix.patch20
2 files changed, 22 insertions, 1 deletions
diff --git a/games-strategy/0ad/0ad-0.0.23b_alpha.ebuild b/games-strategy/0ad/0ad-0.0.23b_alpha.ebuild
index 632db8344465..b059293c8f03 100644
--- a/games-strategy/0ad/0ad-0.0.23b_alpha.ebuild
+++ b/games-strategy/0ad/0ad-0.0.23b_alpha.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -57,6 +57,7 @@ pkg_setup() {
PATCHES=(
"${FILESDIR}"/${PN}-0.0.21_alpha-gentoo.patch
+ "${FILESDIR}"/${PN}-0.0.23b-header_includes_fix.patch
)
src_configure() {
diff --git a/games-strategy/0ad/files/0ad-0.0.23b-header_includes_fix.patch b/games-strategy/0ad/files/0ad-0.0.23b-header_includes_fix.patch
new file mode 100644
index 000000000000..60bf9d1679be
--- /dev/null
+++ b/games-strategy/0ad/files/0ad-0.0.23b-header_includes_fix.patch
@@ -0,0 +1,20 @@
+--- 0ad-0.0.23b-alpha/source/ps/CLogger.h
++++ 0ad-0.0.23b-alpha/source/ps/CLogger.h
+@@ -22,6 +22,7 @@
+ #include <string>
+ #include <set>
+ #include <sstream>
++#include <deque>
+
+ #include "ps/ThreadUtil.h"
+ #include "third_party/cppformat/format.h"
+--- 0ad-0.0.23b-alpha/source/ps/Profiler2GPU.cpp
++++ 0ad-0.0.23b-alpha/source/ps/Profiler2GPU.cpp
+@@ -22,6 +22,7 @@
+
+ #include "precompiled.h"
+
++#include <stack>
+ #include "Profiler2GPU.h"
+
+ #include "lib/ogl.h"