summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/libbonoboui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/libbonoboui')
-rw-r--r--gnome-base/libbonoboui/Manifest1
-rw-r--r--gnome-base/libbonoboui/libbonoboui-2.24.5-r1.ebuild61
-rw-r--r--gnome-base/libbonoboui/metadata.xml5
3 files changed, 67 insertions, 0 deletions
diff --git a/gnome-base/libbonoboui/Manifest b/gnome-base/libbonoboui/Manifest
new file mode 100644
index 000000000000..0b0f79e4f07b
--- /dev/null
+++ b/gnome-base/libbonoboui/Manifest
@@ -0,0 +1 @@
+DIST libbonoboui-2.24.5.tar.bz2 976250 SHA256 fab5f2ac6c842d949861c07cb520afe5bee3dce55805151ce9cd01be0ec46fcd SHA512 163a8f39d9dad7fc3f1afc55b1a779961d285abe2988ff74bfcad4376e9dbfb91bb3e8212f96f48f91c54a6aff749ba6e00ea2d9add10c76b650f3072b875100 WHIRLPOOL 3713f466b6ef3e433fa2988654bc4569f87a51d704d007be2f71e02c720f30f17043b2097b6734b6a8d8f46ac45305815b392578753af1c6f62657c7575aea62
diff --git a/gnome-base/libbonoboui/libbonoboui-2.24.5-r1.ebuild b/gnome-base/libbonoboui/libbonoboui-2.24.5-r1.ebuild
new file mode 100644
index 000000000000..ee348678b19d
--- /dev/null
+++ b/gnome-base/libbonoboui/libbonoboui-2.24.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="User Interface part of libbonobo"
+HOMEPAGE="http://library.gnome.org/devel/libbonoboui/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="examples test"
+
+# GTK+ dep due to bug #126565
+RDEPEND="
+ >=gnome-base/libgnomecanvas-1.116
+ >=gnome-base/libbonobo-2.22
+ >=gnome-base/libgnome-2.13.7
+ >=dev-libs/libxml2-2.4.20:2
+ >=gnome-base/gconf-2:2
+ >=x11-libs/gtk+-2.8.12:2
+ >=dev-libs/glib-2.6.0:2
+ >=gnome-base/libglade-1.99.11:2.0
+ >=dev-libs/popt-1.5
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ x11-apps/xrdb
+ sys-devel/gettext
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+"
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/tests//' -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ if ! use examples; then
+ sed 's/samples//' -i Makefile.am Makefile.in || die "sed 2 failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ addpredict "/root/.gnome2_private"
+ gnome2_src_configure --disable-static
+}
+
+src_test() {
+ addpredict "/root/.gnome2_private"
+ Xemake check
+}
diff --git a/gnome-base/libbonoboui/metadata.xml b/gnome-base/libbonoboui/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-base/libbonoboui/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>