summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-04-04 12:13:54 +0300
committerMart Raudsepp <leio@gentoo.org>2019-04-04 13:59:24 +0300
commit286215dc75bb5722a582017018657c685d8761af (patch)
tree22ab775c7dd5e9c83d852ad7e55f6e767707c932 /gui-libs
parentapp-editors/gnome-latex: fix LICENSE (diff)
downloadgentoo-286215dc75bb5722a582017018657c685d8761af.tar.gz
gentoo-286215dc75bb5722a582017018657c685d8761af.tar.bz2
gentoo-286215dc75bb5722a582017018657c685d8761af.zip
gui-libs/tepl: New package needed by gnome-latex/latexila
This is essentially a new slot of x11-libs/gtef, but without pkgmove, because that old gtef:2 will simply be last rited instead soon, as the only gnome-latex version using gtef (instead of internal code in older or tepl dep in newer) will be removed as soon as x86 re-keywording is done. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/tepl/Manifest1
-rw-r--r--gui-libs/tepl/metadata.xml8
-rw-r--r--gui-libs/tepl/tepl-4.2.0.ebuild54
3 files changed, 63 insertions, 0 deletions
diff --git a/gui-libs/tepl/Manifest b/gui-libs/tepl/Manifest
new file mode 100644
index 000000000000..c1eef7a00386
--- /dev/null
+++ b/gui-libs/tepl/Manifest
@@ -0,0 +1 @@
+DIST tepl-4.2.0.tar.xz 456540 BLAKE2B 8861d2cdcddcb5b9e5aa58798835c0969dd12ce6c5ada69b5b97224f215bfdbf8ee0a7173d5c7cb2cc11894988351ce4df7a81e91e7b7036a48cc89e2cb9dd62 SHA512 32f69c6f0942a82e6b7f94eba776d55dce2af1c8e4c7abadf6af38a0a5abb0a94f0c426d5ec727b8eb478406ba113728b771597c2c84e508b8ccb113a74eab3d
diff --git a/gui-libs/tepl/metadata.xml b/gui-libs/tepl/metadata.xml
new file mode 100644
index 000000000000..996e7cacd217
--- /dev/null
+++ b/gui-libs/tepl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-libs/tepl/tepl-4.2.0.ebuild b/gui-libs/tepl/tepl-4.2.0.ebuild
new file mode 100644
index 000000000000..0837cfd954ba
--- /dev/null
+++ b/gui-libs/tepl/tepl-4.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 virtualx
+
+DESCRIPTION="GtkSourceView-based text editors and IDE helper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gtef"
+
+LICENSE="LGPL-2.1+"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0:4[introspection?]
+ >=gui-libs/amtk-5.0:5[introspection?]
+ >=dev-libs/libxml2-2.5:2
+ app-i18n/uchardet
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${DEPEND}
+ >=sys-devel/gettext-0.19.4
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ # requires running gvfs-metadata
+ sed -e 's:\(g_test_add_func.*/file/load_save_metadata_sync.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/file/load_save_metadata_async.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/file/set_without_load.*\):/*\1*/:' \
+ -i testsuite/test-file-metadata.c || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # valgrind checks not ran by default and require suppression files not in locations where they'd be installed by other packages
+ gnome2_src_configure \
+ --enable-gvfs-metadata \
+ --disable-valgrind \
+ $(use_enable introspection)
+}
+
+src_test() {
+ virtx emake check
+}