summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-07 21:12:59 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-07 21:12:59 -0500
commiteb99bcd7b5744c975da5b2fdd245595ba330794c (patch)
treefbd2d84464378ec7a9c71e32af7d9513b78c79d7 /gui-libs
parentnet-dns/c-ares: arm64 stable (bug #699024) (diff)
downloadgentoo-eb99bcd7b5744c975da5b2fdd245595ba330794c.tar.gz
gentoo-eb99bcd7b5744c975da5b2fdd245595ba330794c.tar.bz2
gentoo-eb99bcd7b5744c975da5b2fdd245595ba330794c.zip
gui-libs/wlroots: add FFMPEG and RDP support and other stuff
* add rdp USE for freerdp * add ffmpeg to RDEPEND * drop old local USE flag rootston * drop old ebuilds Closes: https://bugs.gentoo.org/686872 Closes: https://bugs.gentoo.org/699574 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/Manifest2
-rw-r--r--gui-libs/wlroots/metadata.xml1
-rw-r--r--gui-libs/wlroots/wlroots-0.6.0.ebuild101
-rw-r--r--gui-libs/wlroots/wlroots-0.8.1-r1.ebuild (renamed from gui-libs/wlroots/wlroots-0.7.0.ebuild)8
4 files changed, 5 insertions, 107 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index d69983bcb2f7..9c1e010a4b18 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,3 +1 @@
-DIST wlroots-0.6.0.tar.gz 497934 BLAKE2B a0b631831752e533f83ed62e402ef69b0994df050fd643cf2ef89556face4a822b3936bc758b70ab160eedda8ced16c0992dc209600914095784bba97bd26ee2 SHA512 c205d4303a381e11ef2f4db2faac1ddf9ad85c675824aae9cfe62d9f8bd313f1568d4810db1d006416783b50c8364198648a46d1ba453a0d8f659d6920618286
-DIST wlroots-0.7.0.tar.gz 446392 BLAKE2B ed69ae2e5484428222cd430d7c74935b0801044cacab804ffe3673c5ecf08104a5fbfbaa930c8ef4df3e43de1073910ba970028307a0a3c57483c5d502832292 SHA512 20e7e81bb945cc683c793f1258e83dbeea5e933faa066125f16a24aa7151000c620f9f47cad21540f8bea7d053d181cb89a2803c30fac1b1b9f3345065b9ba9c
DIST wlroots-0.8.1.tar.gz 451814 BLAKE2B 85f221ba9068839f326e09df616f6182f518b9a129730dda794103305e3c0786d609a7cc6cb60a90c9d51cb77e3dbbc5993901271dcf1bd656c7744260561b06 SHA512 da41513de48e00303b31fde620463389103215011c6cc49b9a2420a1529889722aa54f26a211179c528709edb6b90ba2efdae5e4bcef18147d9516f3a94e365a
diff --git a/gui-libs/wlroots/metadata.xml b/gui-libs/wlroots/metadata.xml
index 49eee235ecbd..25975bbdb159 100644
--- a/gui-libs/wlroots/metadata.xml
+++ b/gui-libs/wlroots/metadata.xml
@@ -23,7 +23,6 @@
<use>
<flag name="elogind">Enable support for rootless session via elogind</flag>
<flag name="icccm">Use xcb-icccm (from <pkg>x11-libs/xcb-util-wm</pkg>) util library for improved Xwayland introspection</flag>
- <flag name="rootston">Build the rootston example compositor</flag>
<flag name="x11-backend">Enable support for handling input/output devices through <pkg>x11-libs/libxcb</pkg></flag>
<flag name="X">Enable support for X11 applications (XWayland)</flag>
</use>
diff --git a/gui-libs/wlroots/wlroots-0.6.0.ebuild b/gui-libs/wlroots/wlroots-0.6.0.ebuild
deleted file mode 100644
index 99d9b05be6f3..000000000000
--- a/gui-libs/wlroots/wlroots-0.6.0.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit fcaps meson
-
-DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
-HOMEPAGE="https://github.com/swaywm/wlroots"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="elogind icccm rootston systemd x11-backend X"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- >=dev-libs/libinput-1.9.0:0=
- >=dev-libs/wayland-1.17.0
- media-libs/mesa[egl,gles2,gbm]
- virtual/libudev
- x11-libs/libdrm
- x11-libs/libxkbcommon
- x11-libs/pixman
- elogind? ( >=sys-auth/elogind-237 )
- icccm? ( x11-libs/xcb-util-wm )
- systemd? ( >=sys-apps/systemd-237 )
- x11-backend? ( x11-libs/libxcb:0= )
- X? (
- x11-base/xorg-server[wayland]
- x11-libs/libxcb:0=
- x11-libs/xcb-util-image
- )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.17
- virtual/pkgconfig
-"
-
-FILECAPS=( cap_sys_admin usr/bin/rootston )
-
-src_configure() {
- # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
- local emesonargs=(
- "-Dxcb-errors=disabled"
- -Dlibcap=$(usex filecaps enabled disabled)
- -Dxcb-icccm=$(usex icccm enabled disabled)
- -Dxwayland=$(usex X enabled disabled)
- -Dx11-backend=$(usex x11-backend enabled disabled)
- $(meson_use rootston)
- "-Dexamples=false"
- "-Dwerror=false"
- )
- if use systemd; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
- elif use elogind; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
- else
- emesonargs+=("-Dlogind=disabled")
- fi
-
- meson_src_configure
-}
-
-src_install() {
- if use rootston; then
- dobin "${BUILD_DIR}"/rootston/rootston
- newdoc rootston/rootston.ini.example rootston.ini
- fi
-
- meson_src_install
-}
-
-pkg_postinst() {
- elog "You must be in the input group to allow your compositor"
- elog "to access input devices via libinput."
- if use rootston; then
- elog ""
- elog "You should copy (and decompress) the example configuration file"
- elog "from ${EROOT:-${ROOT}}/usr/share/doc/${PF}/rootston.ini"
- elog "to the working directory from where you launch rootston"
- elog "(or pass the '-C path-to-config' option to rootston)."
- if ! use systemd && ! use elogind; then
- elog ""
- elog "If you use ConsoleKit2, remember to launch rootston using:"
- elog "exec ck-launch-session rootston"
-
- fcaps_pkg_postinst
- fi
- fi
-}
diff --git a/gui-libs/wlroots/wlroots-0.7.0.ebuild b/gui-libs/wlroots/wlroots-0.8.1-r1.ebuild
index 9dcae89da2db..a522d1187389 100644
--- a/gui-libs/wlroots/wlroots-0.7.0.ebuild
+++ b/gui-libs/wlroots/wlroots-0.8.1-r1.ebuild
@@ -13,12 +13,12 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="MIT"
-SLOT="0/7"
-IUSE="elogind icccm systemd x11-backend X"
+SLOT="0/8"
+IUSE="elogind icccm rdp systemd x11-backend X"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -31,6 +31,7 @@ DEPEND="
x11-libs/pixman
elogind? ( >=sys-auth/elogind-237 )
icccm? ( x11-libs/xcb-util-wm )
+ rdp? ( net-misc/freerdp )
systemd? ( >=sys-apps/systemd-237 )
x11-backend? ( x11-libs/libxcb:0= )
X? (
@@ -41,6 +42,7 @@ DEPEND="
"
RDEPEND="
${DEPEND}
+ media-video/ffmpeg:0=
"
BDEPEND="
>=dev-libs/wayland-protocols-1.17