summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:13:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:46:08 +0200
commit2de492f66f593f97c84056a21259aaa5653681dd (patch)
treefe20d10d8a88b87b3b6ef55c8ac06f5b3621c0f0 /kde-apps/ark
parentkde5.eclass: Disable kdoctools_install(po) if KDE_HANDBOOK=forceoptional (diff)
downloadgentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.gz
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.bz2
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.zip
kde-apps: Add KDE Applications 17.04.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-17.04.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index b6cb50cec900..1575b863a828 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-16.12.3.tar.xz 1348616 SHA256 a0e54892a809d9b805aab95d33060560480a5575df2e8afbd6fc0eb074ee2b60 SHA512 2bb7c80758bc0a3322892b66cbe26dad199661e1bbbf71fb0ccc2bc1bea8dac8f267fc371baf55a4674e5bc67f86fb39587709d12e10e53988fa1a6c0e056956 WHIRLPOOL 35cd9f15f7a04b99b09fce32c6ce3819ed7b7c6e0d2240517ccf942a15622f0f10a19c758c5195c44ba9c5e4a451673073c0cedaad12d9970618867bf17d3126
DIST ark-17.04.0.tar.xz 1884736 SHA256 93c320d077f65aa9175ea18150e29a2f4f6cbc0979b98b87dd575e105c126862 SHA512 a8313bb83ee2169a9e8be025082948912c920264c92f33538344ce2c751f6f4b033f80a7fc3eefd3fd8eaa4ae0524aa3eba0cc06182cf5b7cb21c6f6f57b98bc WHIRLPOOL 907e216fb1aeadc8cfb5257298c3c2b931fc935c07d1ef1659a772d62ab5279b1cd4e4b2a4178f922305de2651adc681286de8f65fa05699aefa4a70fedfa285
+DIST ark-17.04.1.tar.xz 1886488 SHA256 b642dc57aa1a22e0bc9757d3154a35da3a91bd2917ef03b74e82ee304d9d3223 SHA512 64c09853fc5eea74533220e686f9a01750a55f2dff71a06d30e9db1fb01816f481a710f39407c1b2410d62815816b8ee5cc94bfb39172aca99c70a0a48f8618e WHIRLPOOL 4a6242d27262fd333a4a132041b743cbef788c4efd8de2b2a545b245d9584bf9fa4ef57744b9846be16f33471b43f59944a195b9b454d035a9f570697d34fe9e
diff --git a/kde-apps/ark/ark-17.04.1.ebuild b/kde-apps/ark/ark-17.04.1.ebuild
new file mode 100644
index 000000000000..3ba7d3c0e61d
--- /dev/null
+++ b/kde-apps/ark/ark-17.04.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip zlib"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib?]
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ $(cmake-utils_use_find_package zlib ZLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}