summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 21:10:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 21:11:17 +0200
commitcace445d5118ee027dc43f829fc50f27d623134c (patch)
tree2dfaad77bd443bf2f28d49d3bcf8c2880aa92ff3 /kde-apps/cantor
parentdev-util/rbtools: maintainer-needed (diff)
downloadgentoo-cace445d5118ee027dc43f829fc50f27d623134c.tar.gz
gentoo-cace445d5118ee027dc43f829fc50f27d623134c.tar.bz2
gentoo-cace445d5118ee027dc43f829fc50f27d623134c.zip
kde-apps: Add KDE Applications 19.08.1
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/cantor')
-rw-r--r--kde-apps/cantor/Manifest1
-rw-r--r--kde-apps/cantor/cantor-19.08.1.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/kde-apps/cantor/Manifest b/kde-apps/cantor/Manifest
index fbfc316d1958..dcfc34c8d600 100644
--- a/kde-apps/cantor/Manifest
+++ b/kde-apps/cantor/Manifest
@@ -1,2 +1,3 @@
DIST cantor-19.04.3.tar.xz 2523496 BLAKE2B 59b7267eb8ac13aefc25e706bfb29e7430a59ecd7e92c69ff76032cbdf199cc9eee017f71bd2f0736e05dde09963de1926849d77678d15af6d1599795ff7402b SHA512 bfbb598e7fb4c61bddad0ef91802107a268121493146e7105d0c41450e3803b26b40363cc8fa69990f309aadb3bfefacb3fbb7dda75a3f274d70506c53d79ad4
DIST cantor-19.08.0.tar.xz 2536776 BLAKE2B 2c0c536dff462c3dee868f9e23fd9bf5f058246cec0999009b7b5b88cf9461e3925070a11790cfe61ce9019d7dcb3569127bf3bb29d4d3065a59a414c1590603 SHA512 ed40d123211b7f1585affcd88fa9549d15ebcda3fa23cdbb6ea7fc932eb79b3d84428cc0552350644faebded17088887d0e3dcda5635c4ac69df56be395a63a1
+DIST cantor-19.08.1.tar.xz 2539272 BLAKE2B f95470d9bf5aeacac105f0b980b3e987ae472f14d76aec159a6ca3a1a3e0600253a3a41ca32e4b23694caee80876e3375e64362510564c5732e077f1dd4595be SHA512 b2f789905133880de99039cdae81698ed869860167f644c6898dd5e483eb0c4a479b6f5b3c5d2b6bfaddf30a4434224fdf517eaeb8aa77949e192c35b769f8ef
diff --git a/kde-apps/cantor/cantor-19.08.1.ebuild b/kde-apps/cantor/cantor-19.08.1.ebuild
new file mode 100644
index 000000000000..181b280d4be7
--- /dev/null
+++ b/kde-apps/cantor/cantor-19.08.1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit kde5 python-single-r1
+
+DESCRIPTION="Interface for doing mathematics and scientific computing"
+HOMEPAGE="https://kde.org/applications/education/cantor https://edu.kde.org/cantor/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+analitza julia lua markdown postscript python qalculate R"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep syntax-highlighting)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ analitza? ( $(add_kdeapps_dep analitza) )
+ julia? ( dev-lang/julia )
+ lua? ( dev-lang/luajit:2 )
+ markdown? ( >=app-text/discount-2.2.2 )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate:=
+ )
+ postscript? ( app-text/libspectre )
+ python? (
+ ${PYTHON_DEPS}
+ $(add_qt_dep qtdbus)
+ )
+ R? ( dev-lang/R )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT+=" test"
+
+pkg_pretend() {
+ kde5_pkg_pretend
+
+ if ! has_version sci-mathematics/maxima && ! has_version sci-mathematics/octave && \
+ ! use analitza && ! use julia && ! use lua && ! use python && ! use qalculate && ! use R; then
+ elog "You have decided to build ${PN} with no backend."
+ elog "To have this application functional, please enable one of the backends via USE flag:"
+ elog " analitza, lua, python, qalculate, R"
+ elog "Alternatively, install one of these:"
+ elog " # emerge sci-mathematics/maxima (bug #619534)"
+ elog " # emerge sci-mathematics/octave"
+ elog "Experimental available USE flag:"
+ elog " julia (not stable, bug #613576)"
+ elog
+ fi
+
+ if ! has_version virtual/latex-base; then
+ elog "For LaTeX support:"
+ elog " # emerge virtual/latex-base"
+ fi
+}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_configure() {
+ use julia && addpredict /proc/self/mem # bug 602894
+
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonLibs=ON
+ $(cmake-utils_use_find_package analitza Analitza5)
+ $(cmake-utils_use_find_package julia Julia)
+ $(cmake-utils_use_find_package lua LuaJIT)
+ $(cmake-utils_use_find_package markdown Discount)
+ $(cmake-utils_use_find_package postscript LibSpectre)
+ $(cmake-utils_use_find_package python PythonLibs3)
+ $(cmake-utils_use_find_package qalculate Qalculate)
+ $(cmake-utils_use_find_package R R)
+ )
+ kde5_src_configure
+}