summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:13:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:46:08 +0200
commit2de492f66f593f97c84056a21259aaa5653681dd (patch)
treefe20d10d8a88b87b3b6ef55c8ac06f5b3621c0f0 /kde-apps/dolphin
parentkde5.eclass: Disable kdoctools_install(po) if KDE_HANDBOOK=forceoptional (diff)
downloadgentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.gz
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.bz2
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.zip
kde-apps: Add KDE Applications 17.04.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-17.04.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 883b5058e6c7..28d2e0fbe099 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-16.12.3.tar.xz 676192 SHA256 62f1392a25692bc7ff0ffba89b1949beba3cba0f78bdf6acdf97ac2897a46578 SHA512 99a6f35678918dffa7a55b453705186a92bf1b69776a7b80ef12553489e258f5776a5d7b2a5dd16cbdb2e6772a2a122fe10e74afb6233e7a939f8f925e1d8736 WHIRLPOOL e606fbb6567f0c67e952ac91e9e54fcb7734a493091cd6441f3ccb8d42739f680ff52c90b004d6ad5d3a97e0f68bb2b031b3d432be38ae20e9a4d8d01ffc5893
DIST dolphin-17.04.0.tar.xz 4714124 SHA256 be98d39a63e1fb9a77d79fbb04019cecaf0452d0616d518518e71d2c3fbe2227 SHA512 dc5fbd343e5f8f43694d6c024f72c00a9fe3274f9b718c2c9d11b8ee36001a85162e109c3c71cc5c1b4dbf8746fdd4076f32f6732ebfc546d4c862568e4f6435 WHIRLPOOL 548f4c2b00b193ad231406e33df3f43edd22ce478f8d366a0a84801db1eaabc2f10b28cfd0767bbe85023a73585ab357d8e8952a05955c9f974b67caf4d60adc
+DIST dolphin-17.04.1.tar.xz 4713172 SHA256 27ae075eeb5811c4a3b2f64edb7316c17ac114bb1fa7ee866cc04def99352be7 SHA512 10fffef1c498372522c30d0e52ed30ea9271eadf6dd1a400416adb2dc360f5f78605babb6e5336a8376661caffea90b4b1deafcdbbd1ef1ddb3ae2e633da56c6 WHIRLPOOL f0019878016dc232e80d4ab5fe173b2f88bffc3bfe7ba59257548c5f99b8d25a4ce84545a3fa0362fd7bb6adbc0841f24e2d7c455d2ec87e5d2edb05c1b24b19
diff --git a/kde-apps/dolphin/dolphin-17.04.1.ebuild b/kde-apps/dolphin/dolphin-17.04.1.ebuild
new file mode 100644
index 000000000000..6851edf8232c
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-17.04.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FRAMEWORKS_MINIMAL="5.30.0"
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://dolphin.kde.org https://www.kde.org/applications/system/dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ fi
+}