summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:21:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:58:09 +0200
commitc1063afea17a29bb75dbbbf0121fa5c8ad948574 (patch)
treec62ccf9ec787742c39c2afd14ac1198894802629 /kde-apps/dolphin
parentmedia-libs/libqaccessibilityclient: New package (diff)
downloadgentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.gz
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.bz2
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.zip
kde-apps: Add KDE Applications 17.08.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-17.08.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 3e3e81d8f714..1af608197c44 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1 +1,2 @@
DIST dolphin-17.04.3.tar.xz 4708604 SHA256 4a987f456f0090bc527333cdbc9e9c41d56e5ca223c7f29839d4a000b99017e1 SHA512 8e7cb264395ff0d0f16727c0979373b1bad79cc94c1878bf31c2004dfba4c259de53f24c19ff975f28308a8876ad1297db133d813ec4aa4d1bd22e7391079cc0 WHIRLPOOL a2f0146a6fe53ddd0ad180acfbe850c2cff74f7d5400a7f49f3c92d00fa2d2403f56e605bd59ea23d7d053239fa37e1c3e567739c98050f7c37df5ebed06252a
+DIST dolphin-17.08.0.tar.xz 4727732 SHA256 3981d735f7fccba22eda72a35b8d059afb4e57f79ead5caf3c643f550752afbb SHA512 e38d4baffce5649276d9dfffda6a08d1d08417f84c66dbf0d224443135217d232e75a0d45c87ec40668d7ee080921f54d687c273627d21ef1e54754245deeabb WHIRLPOOL 08a98c7157e626e0df3552005f17c59e7606da10ae7a7ff4b01a92ab7c3ae4f248679944d630cda683928cdc857678ee47e402d434e3565dbdd36f0a3d5946fb
diff --git a/kde-apps/dolphin/dolphin-17.08.0.ebuild b/kde-apps/dolphin/dolphin-17.08.0.ebuild
new file mode 100644
index 000000000000..f1e0c49b1e55
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-17.08.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://dolphin.kde.org https://www.kde.org/applications/system/dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ fi
+}