summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-29 01:20:43 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-29 01:21:50 +0200
commite51f152cde1e609553ca5712df2f7ad9a4e40ca8 (patch)
tree66467a159898b0395663f2c6c9cf401c516f6205 /kde-apps/konsole
parentsys-devel/gcc: cut patchset 1 for live ebuilds, bug #725682 (diff)
downloadgentoo-e51f152cde1e609553ca5712df2f7ad9a4e40ca8.tar.gz
gentoo-e51f152cde1e609553ca5712df2f7ad9a4e40ca8.tar.bz2
gentoo-e51f152cde1e609553ca5712df2f7ad9a4e40ca8.zip
kde-apps/konsole: Fix segfault on session close
KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=415762 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsole')
-rw-r--r--kde-apps/konsole/files/konsole-20.04.1-segfault-on-close.patch44
-rw-r--r--kde-apps/konsole/konsole-20.04.1-r2.ebuild68
2 files changed, 112 insertions, 0 deletions
diff --git a/kde-apps/konsole/files/konsole-20.04.1-segfault-on-close.patch b/kde-apps/konsole/files/konsole-20.04.1-segfault-on-close.patch
new file mode 100644
index 000000000000..55213878ad27
--- /dev/null
+++ b/kde-apps/konsole/files/konsole-20.04.1-segfault-on-close.patch
@@ -0,0 +1,44 @@
+From 5e5129d51fa85036832f1af44ec5b875d426392f Mon Sep 17 00:00:00 2001
+From: Maximilian Schiller <manimax3@outlook.de>
+Date: Thu, 28 May 2020 22:57:29 +0200
+Subject: [PATCH] Fix konsolepart Segfault when closed
+
+Assign the _view as the parent to the KXMLGuiFactory because the factory
+is referencing the view widget as its associated widget. Since the
+TerminalDisplay gets destructed first this is now a dangling pointer.
+If the view is set as the parent the factory gets cleaned up correctly.
+
+Also cleanup the created clientBuilder after destruction because it
+cant have a parent and would probably leak memory.
+
+BUG: 415762
+BUG: 421226
+BUG: 421194
+BUG: 421138
+---
+ src/SessionController.cpp | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/SessionController.cpp b/src/SessionController.cpp
+index e72f342c4..99e185f5e 100644
+--- a/src/SessionController.cpp
++++ b/src/SessionController.cpp
+@@ -1732,11 +1732,13 @@ void SessionController::showDisplayContextMenu(const QPoint& position)
+ if (factory() == nullptr) {
+ if (clientBuilder() == nullptr) {
+ setClientBuilder(new KXMLGUIBuilder(_view));
++
++ // Client builder does not get delted automatically
++ connect(this, &QObject::destroyed, this, [this]{ delete clientBuilder(); });
+ }
+
+- auto factory = new KXMLGUIFactory(clientBuilder(), this);
++ auto factory = new KXMLGUIFactory(clientBuilder(), _view);
+ factory->addClient(this);
+- ////qDebug() << "Created xmlgui factory" << factory;
+ }
+
+ QPointer<QMenu> popup = qobject_cast<QMenu*>(factory()->container(QStringLiteral("session-popup-menu"), this));
+--
+2.26.2
+
diff --git a/kde-apps/konsole/konsole-20.04.1-r2.ebuild b/kde-apps/konsole/konsole-20.04.1-r2.ebuild
new file mode 100644
index 000000000000..95fd7ffcee35
--- /dev/null
+++ b/kde-apps/konsole/konsole-20.04.1-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+KFMIN=5.70.0
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KDE's terminal emulator"
+HOMEPAGE="https://kde.org/applications/system/org.kde.konsole
+https://konsole.kde.org"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="X"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kinit-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kpty-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-crash-on-close.patch" # bug 723214, in 20.04.2
+ "${FILESDIR}/${P}-qt-5.15-set-text-encoding-crash.patch" # KDE-Bug 419526; pending
+ "${FILESDIR}/${P}-segfault-on-close.patch" # KDE-Bug 415762; pending
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}