summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-09 18:20:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-09 18:23:07 +0100
commit101f20b293d1a063a2a1237a3beeac631704d3e5 (patch)
tree4cc6096c25b56aa84df9d4b7a9d5826fae4d4d66 /kde-apps/konsolekalendar
parentsys-kernel/vanilla-kernel-bin: Bump to 4.19.94 LTS (diff)
downloadgentoo-101f20b293d1a063a2a1237a3beeac631704d3e5.tar.gz
gentoo-101f20b293d1a063a2a1237a3beeac631704d3e5.tar.bz2
gentoo-101f20b293d1a063a2a1237a3beeac631704d3e5.zip
kde-apps: Add KDE Applications 19.12.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-19.12.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index 43b924ab180d..4cf1062c4e88 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-19.08.3.tar.xz 223564 BLAKE2B e0d9f01659a471307db2c7d8c0906297ec4a880cb0019414520b29a14eee68bf39b02d02dd4e5b3b03c3684022f675f30cdb6efb214adaca64dc27f5eec03c25 SHA512 4cc146da96f6a006749e4c3e0962155fc8bcd788d2ed39adbbe73f1d82bc4264349ce06a9b524ff4fb1a1675e0d66345e5bbad8044360b6fe28d9565672f3922
DIST akonadi-calendar-tools-19.12.0.tar.xz 223424 BLAKE2B 042182b9884f5b81f91eec2a92e37db9244ce30b4360358f958dbaf317e2bd6d1b5a8c40e8336d0560b4cfac9f3428511459435d40f723f9f9832b190efff601 SHA512 90df1342f3685df0c0496d83dc1b483d0c126bbc7ad03d6abd51c421c5edeae18b3b677b790e3646f55bfd37d27d9aaa0f484ac8983755de20b187efed34cd76
+DIST akonadi-calendar-tools-19.12.1.tar.xz 223748 BLAKE2B 94850f9537b51468b6c91cbb6203b3fa6ff6dc4019beb1d1e852c594cc82e24855817f91ca5ba54273ab2bb60fadcf0f55d6b9c3cd91f863cb9fb16ebda78ad6 SHA512 aa3741db2df022b3669f10d1dc988380ff88b9595653fc77314b97910ef8c2f25193d159b8e86a347f773f0a6a09633ef82ba71a1fc2d769ee50a3f3c501668e
diff --git a/kde-apps/konsolekalendar/konsolekalendar-19.12.1.ebuild b/kde-apps/konsolekalendar/konsolekalendar-19.12.1.ebuild
new file mode 100644
index 000000000000..2e5e8c0a5318
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-19.12.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+inherit ecm kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}