summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-15 15:08:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-15 15:09:32 +0200
commit54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9 (patch)
treeb1b36d8867b77df28e956c3f88378ef5518961f9 /kde-apps/konsolekalendar
parentkde-misc/kio-gdrive: Pin kde-apps/libkgapi version to <19.04.50 (diff)
downloadgentoo-54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9.tar.gz
gentoo-54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9.tar.bz2
gentoo-54d6ee8b4a5a60e7f3f7e1a2068c2ee69f9cd1d9.zip
kde-apps: Add KDE Applications 19.08.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-19.08.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index 275fd905024b..6ad100e6ae63 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1 +1,2 @@
DIST akonadi-calendar-tools-19.04.3.tar.xz 223328 BLAKE2B 47f16a483f49f27d203db3b0627532b7b928f18bead7e22176b340698e7c2e52322139ca92cae9a776b239d9d741656ec3c943eb997c1dd5064da4d818610474 SHA512 d4c61f04861b26fb01b0cd76056fa5107e0257e7b2c118596ed40d87a3cffa8526889bc82b45f9d3cc61d1d4d25518bbeca56edaa028d02f779b7880df2522e5
+DIST akonadi-calendar-tools-19.08.0.tar.xz 223680 BLAKE2B 28525271249ae2b8f77dba267a977d96c79b2409c8e3bbb06368742dd754c5e045ab2ff8c2e0e51d992b869915da1996d8c697aa137d80ca657b3afb2849ab9e SHA512 170b94f1f837aceb723d130929f42c0f57504dad510195128e23519702d26a1a39ae3f74c4386471070a44b9c4bced2b5fecb566faae8bf51ca82984a718b83e
diff --git a/kde-apps/konsolekalendar/konsolekalendar-19.08.0.ebuild b/kde-apps/konsolekalendar/konsolekalendar-19.08.0.ebuild
new file mode 100644
index 000000000000..bb7f42fb2202
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-19.08.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KMNAME="akonadi-calendar-tools"
+inherit kde5
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}