summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 18:45:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 20:44:16 +0200
commit574a1e63fb59f2333adc047a9c3f2b929101e540 (patch)
tree370dfcc1bdb5ae3dc6a6233f2717d396155ac9f0 /kde-apps/konsolekalendar
parentnet-dns/dnsdist: initscript fix (diff)
downloadgentoo-574a1e63fb59f2333adc047a9c3f2b929101e540.tar.gz
gentoo-574a1e63fb59f2333adc047a9c3f2b929101e540.tar.bz2
gentoo-574a1e63fb59f2333adc047a9c3f2b929101e540.zip
kde-apps: Add KDE Applications 19.04.1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-19.04.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index 42a6cac5db54..66e04dab3a99 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-18.12.3.tar.xz 225324 BLAKE2B 04432c5a7b65087ff037ae0b0231445830782fe1f79c77f33c0f25af5509180d00855803f33661af230eacb19be0fdcb33aeda157a12cd1ef659b40cf3bf6088 SHA512 aaeba0398f24389e4371deef583688b9349b5aa248ded914e62ba3a690b99963d7b4fd78c990123fbcc8656e5ac49ba874a4fd81827f3c862f7401c54924e285
DIST akonadi-calendar-tools-19.04.0.tar.xz 223700 BLAKE2B 19d8523a002bf537b08ec94d00eeeee40b3512192f89d3ae1220afc7092cbf43035ecc14087d5c141ed620adfb5ad9da443f168f3f32ea7190f3f91f572e7287 SHA512 b778865aab2d9bca00318429e69cae8e7af3032de75dfabf0c15c9e26874b96407c290b809239eac89070beb3fac2129b8c27115b07ac0a18ce2741e2a088524
+DIST akonadi-calendar-tools-19.04.1.tar.xz 223668 BLAKE2B aa658b92c19303d1332e6496ed8e97f398494ea690c2593b71382deddcedeb8f7adee957f00f1e2b594fb97f242f750bb1727d0785c53e89b26c98979b34cba4 SHA512 84d5fa29308c7f07964e868a229e39cd55d30d2d4a44a8df4440d426322b1cd5ac816c6cf07c2011875b404fdee08ee090407258bdbff25784bf95731ac836cc
diff --git a/kde-apps/konsolekalendar/konsolekalendar-19.04.1.ebuild b/kde-apps/konsolekalendar/konsolekalendar-19.04.1.ebuild
new file mode 100644
index 000000000000..bb7f42fb2202
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-19.04.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KMNAME="akonadi-calendar-tools"
+inherit kde5
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}