summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-14 17:13:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 07:36:14 +0200
commite19edabff80707de8772078358c8a9ca1169ca91 (patch)
treeb15a6cde4e36de6ddebe6a9e3d015312dc40dc8d /kde-apps/konsolekalendar
parentkde5-functions.eclass: Update minimum deps (diff)
downloadgentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.gz
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.bz2
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.zip
kde-apps: Add KDE Applications 19.04.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-19.04.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index d0bfc954d7e0..f1b54a9bf379 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-18.12.3.tar.xz 225324 BLAKE2B 04432c5a7b65087ff037ae0b0231445830782fe1f79c77f33c0f25af5509180d00855803f33661af230eacb19be0fdcb33aeda157a12cd1ef659b40cf3bf6088 SHA512 aaeba0398f24389e4371deef583688b9349b5aa248ded914e62ba3a690b99963d7b4fd78c990123fbcc8656e5ac49ba874a4fd81827f3c862f7401c54924e285
DIST akonadi-calendar-tools-19.04.2.tar.xz 223244 BLAKE2B fcbafbb3ec103abf8a26d23c1240da3bac887f30fdb9c731d3b5f31921633d5d0891214b0a46de20eb8618d3a436a70490c11b10021c4d0c4ec2507d8fac15c2 SHA512 91f7183fa7bca447b166b236b817ebe79140cc2d143125c13639903d032fdd4731da9404d921cc36f72cbe48e88a1fbb9fb4288d516a2151f5458ad4c7fae239
+DIST akonadi-calendar-tools-19.04.3.tar.xz 223328 BLAKE2B 47f16a483f49f27d203db3b0627532b7b928f18bead7e22176b340698e7c2e52322139ca92cae9a776b239d9d741656ec3c943eb997c1dd5064da4d818610474 SHA512 d4c61f04861b26fb01b0cd76056fa5107e0257e7b2c118596ed40d87a3cffa8526889bc82b45f9d3cc61d1d4d25518bbeca56edaa028d02f779b7880df2522e5
diff --git a/kde-apps/konsolekalendar/konsolekalendar-19.04.3.ebuild b/kde-apps/konsolekalendar/konsolekalendar-19.04.3.ebuild
new file mode 100644
index 000000000000..bb7f42fb2202
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-19.04.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KMNAME="akonadi-calendar-tools"
+inherit kde5
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}