summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-05 20:21:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-05 20:38:59 +0100
commit7836d95e3288b0b6490c8ee89fde81e0d9e2786d (patch)
treefcec0fe6c0421764ef6a753fc402cbd18e8607b2 /kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.12.3.ebuild
parentmedia-libs/libvpx: move build deps to BDEPEND (diff)
downloadgentoo-7836d95e3288b0b6490c8ee89fde81e0d9e2786d.tar.gz
gentoo-7836d95e3288b0b6490c8ee89fde81e0d9e2786d.tar.bz2
gentoo-7836d95e3288b0b6490c8ee89fde81e0d9e2786d.zip
kde-apps: Add KDE Release Service 19.12.3
Package-Manager: Portage-2.3.92, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.12.3.ebuild')
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.12.3.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.12.3.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.12.3.ebuild
new file mode 100644
index 000000000000..f19be29f7dab
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.12.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/KTp"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="experimental"
+
+BDEPEND="
+ dev-util/intltool
+"
+COMMON_DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-apps/kaccounts-integration-${PVCUT}:5
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5(+)]
+"
+DEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ >=kde-apps/kaccounts-providers-${PVCUT}:5
+ net-im/telepathy-connection-managers
+"
+
+src_prepare() {
+ if use experimental; then
+ mv data/kaccounts/disabled/*.in data/kaccounts/ || \
+ die "couldn't enable experimental services"
+ fi
+ ecm_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+ ecm_pkg_postinst
+}