summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 12:40:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 16:29:37 +0200
commit77996f0bd46af757187d387e251f25fdf21a33f8 (patch)
tree18c9cc45de05d82b4e08b5966b62d51dc802872e /kde-apps/ktp-accounts-kcm
parentwww-client/opera-beta: Old (diff)
downloadgentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.gz
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.bz2
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.zip
kde-apps: Add KDE Applications 19.04.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'kde-apps/ktp-accounts-kcm')
-rw-r--r--kde-apps/ktp-accounts-kcm/Manifest1
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.04.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/Manifest b/kde-apps/ktp-accounts-kcm/Manifest
index 56f12f87c61b..310028b7f0d9 100644
--- a/kde-apps/ktp-accounts-kcm/Manifest
+++ b/kde-apps/ktp-accounts-kcm/Manifest
@@ -1 +1,2 @@
DIST ktp-accounts-kcm-18.12.3.tar.xz 261760 BLAKE2B b6cf1ddff755970f3fa7d0de1509dcf01c2e461814a931a3541284efcac1ede32a748dc0f564e21c3ae849e52bbb32e030024666a50eb56aad6f46e289e1f7ec SHA512 80170d943186ec446d571f621a8f5e3edadf4385bb7e8cdc2fd46ca201612627da9aa0797da9c9c8162f2eec7d9f6ce9986a96ffa700d07a43ccd4b58796ede8
+DIST ktp-accounts-kcm-19.04.0.tar.xz 261536 BLAKE2B 67b361200c8c67f9bcac80cc3ac384f608d2f9dfdc3539d5aedcb741c6b8f728bc3d6b760c8c07302bfa636f7cd51dab4651c74f4936d82d6e53fcc0649c6fcb SHA512 406b1c777456aad3094fed158f27d1b7c3b85f2877826fb8ebae2f3752c205a3a9b95b6b56e4fa14e8921df30164307a41c07057df09934dbd1f1a0ca96363ee
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.04.0.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.04.0.ebuild
new file mode 100644
index 000000000000..9e36e7d45e41
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.04.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="experimental"
+
+BDEPEND="
+ dev-util/intltool
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5(+)]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kio)
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kaccounts-providers)
+ net-im/telepathy-connection-managers
+"
+
+src_prepare() {
+ if use experimental; then
+ mv "${S}"/data/kaccounts/disabled/*.in "${S}"/data/kaccounts/ || \
+ die "couldn't enable experimental services"
+ fi
+ kde5_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+ kde5_pkg_postinst
+}