summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 00:11:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 13:59:58 +0100
commit7f45ce7728de31bb839db16ab19319f026ab0add (patch)
tree460a42bf534d6aa491db847a52a3026e3758c161 /kde-apps/ktp-text-ui
parentkde-apps/gwenview: Backport exiv2-0.27 support to 18.08.3 (diff)
downloadgentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.gz
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.bz2
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.zip
kde-apps: Add KDE Applications 18.12.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktp-text-ui')
-rw-r--r--kde-apps/ktp-text-ui/Manifest1
-rw-r--r--kde-apps/ktp-text-ui/ktp-text-ui-18.12.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/ktp-text-ui/Manifest b/kde-apps/ktp-text-ui/Manifest
index b1919127d194..39034f98e51f 100644
--- a/kde-apps/ktp-text-ui/Manifest
+++ b/kde-apps/ktp-text-ui/Manifest
@@ -1,2 +1,3 @@
DIST ktp-text-ui-18.08.3.tar.xz 469856 BLAKE2B 27bdcdec15cdaeb692194f1e085dae0e8d2d3a6f913b5631ffb7195b2a62ca8b37dd02971515ad31024704eedf8f5b1a4e3225f211461021ff550651a27e62a7 SHA512 a3d46895d501156ebb6727e3b5bd6b4c0b6f202a77d5cdf557c6a15658d514ea692cc3f1cdeb59e18d45cdedc1387225816655e0c6e129b78ed8e7a6c1cd5444
DIST ktp-text-ui-18.12.1.tar.xz 465884 BLAKE2B 659ffbf80cfde4d42d691c0d1eea1bb8a5fe1f05f46d1fa49addd154d597e50259a60d49b1a0c24361a09ca51ad2f5ceb1d31dc190dbf98d5fd851a76f18f14c SHA512 17e48cbb5646cce61be7e775a742a491ef7ab9a44136eb224fcb0ba9d35bc3162b2887c291a6e39ba8f16198b107acaf0763b6d41213e949e9407da859f1b944
+DIST ktp-text-ui-18.12.2.tar.xz 465980 BLAKE2B 2045b803b1651490b195bd502fbca0c849cb6bb7c4a405fc440471d91774dd0d359c03ae4c9cd40ea13ffd45c63b340d3174d79b8b8bcd9acf6086c84f5e8173 SHA512 742349312b1370288709b64d2b9c8589c13a609c22a62392a85243eb39243e47b29d5d2c3f409046e6812d675c1c17a8b50a06b50b1eb8909483d8b11f30f2de
diff --git a/kde-apps/ktp-text-ui/ktp-text-ui-18.12.2.ebuild b/kde-apps/ktp-text-ui/ktp-text-ui-18.12.2.ebuild
new file mode 100644
index 000000000000..39711660098e
--- /dev/null
+++ b/kde-apps/ktp-text-ui/ktp-text-ui-18.12.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy text chat window"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="Apache-2.0 || ( AFL-2.1 BSD ) GPL-2+ LGPL-2.1+ MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kpeople)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_kdeapps_dep ktp-common-internals otr)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ net-libs/telepathy-qt[qt5(+)]
+ speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep ktp-contact-list)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}