summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 00:11:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 13:59:58 +0100
commit7f45ce7728de31bb839db16ab19319f026ab0add (patch)
tree460a42bf534d6aa491db847a52a3026e3758c161 /kde-apps/libkcddb
parentkde-apps/gwenview: Backport exiv2-0.27 support to 18.08.3 (diff)
downloadgentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.gz
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.bz2
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.zip
kde-apps: Add KDE Applications 18.12.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/libkcddb')
-rw-r--r--kde-apps/libkcddb/Manifest1
-rw-r--r--kde-apps/libkcddb/libkcddb-18.12.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-apps/libkcddb/Manifest b/kde-apps/libkcddb/Manifest
index b4bfe00b3379..5c5369cfcbb9 100644
--- a/kde-apps/libkcddb/Manifest
+++ b/kde-apps/libkcddb/Manifest
@@ -1,2 +1,3 @@
DIST libkcddb-18.08.3.tar.xz 426900 BLAKE2B dc5267b33ae715b95b9b40f36737e2c42ccbb6686580eb087ce86b7e156109bfc6f605b4a32cbacbcb01e0aff76ca26790173f64927f8745d16826b251e5c0d1 SHA512 07c91d8e53c2b30bfc2ca1e13aaae793ff88fc79d57475d32aa6cb392c6cd36b174ed8b5ab185a2a625d1fea29067b813b46985ecaca15510d8094fe32a5193d
DIST libkcddb-18.12.1.tar.xz 426576 BLAKE2B b19463f7850ecaa9b857bea654d711f6f58b422f11ea5912c9805c2f6e1c05abf617c14ff20e4d2c9f34b2847b6e38b2096b0a125a2d5a3df31108862d98c16e SHA512 9936c6543a5864b87ca2a229ce4fae2a86a5100747d0bb9e4980e4a0073337725c8be1eff66584e6fabfffc17150fd0fb24f3f9f10df4fa6547b641f939889df
+DIST libkcddb-18.12.2.tar.xz 426604 BLAKE2B c754a54f12e620a62b87d0ed8b17d4370f4ee849f6b3daeb8dc4b33c5f759044dbc90e62d18689ae9ed282a0e130fb2cc2796a38f7ce5d47fd2c799ddba4cf16 SHA512 1477089e289971f6af787ed56aa3b91733aa5ba7ba74840cbeefbc29de8d9905eac46930e2764c1043634f986f0bb6fefe617c8c110682ace0e11f4efe60fe00
diff --git a/kde-apps/libkcddb/libkcddb-18.12.2.ebuild b/kde-apps/libkcddb/libkcddb-18.12.2.ebuild
new file mode 100644
index 000000000000..b23e56286058
--- /dev/null
+++ b/kde-apps/libkcddb/libkcddb-18.12.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE library for CDDB"
+LICENSE="GPL-2+ handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="musicbrainz"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ musicbrainz? ( media-libs/musicbrainz:5 )
+"
+RDEPEND="${DEPEND}"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use handbook ; then
+ pushd kcmcddb > /dev/null
+ cmake_comment_add_subdirectory doc
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package musicbrainz MusicBrainz5)
+ )
+
+ kde5_src_configure
+}