summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 12:40:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 16:29:37 +0200
commit77996f0bd46af757187d387e251f25fdf21a33f8 (patch)
tree18c9cc45de05d82b4e08b5966b62d51dc802872e /kde-apps/lokalize
parentwww-client/opera-beta: Old (diff)
downloadgentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.gz
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.bz2
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.zip
kde-apps: Add KDE Applications 19.04.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'kde-apps/lokalize')
-rw-r--r--kde-apps/lokalize/Manifest1
-rw-r--r--kde-apps/lokalize/lokalize-19.04.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/lokalize/Manifest b/kde-apps/lokalize/Manifest
index f7507303cde0..9c2693463d2a 100644
--- a/kde-apps/lokalize/Manifest
+++ b/kde-apps/lokalize/Manifest
@@ -1 +1,2 @@
DIST lokalize-18.12.3.tar.xz 2312372 BLAKE2B b3606fa3f831f91175a9abeeb6a726c94c4c7e0e5a8758dc15c89d2a662e1c7580ad33921735be0e2dfc7860adcc5544bc48b18c3dd567bc35aadf6643b80359 SHA512 3edb3a357b6f5a0df65db4c769260e23231c0dc42b5cf980dc9fe585f62420115f15880cc38e0ae105cf27521736edd1f8faa23315a54731316a095393fde42f
+DIST lokalize-19.04.0.tar.xz 1680008 BLAKE2B 3c95be31f3a92c03d147ab598338ca70b08f68c5e3db714e554372ac742d880ed49f61730bdda142ed48fc4a3ab7388899207e0e6ff8a9a5b29fca03da2afb4b SHA512 fa2ab79d72f4a7baf43b8fb27fa27e8c33aebf8d4c1aad51da9ac86c45ec9835a37b0143aedcd481823d7302a87e8d09101b7b60504184532a1ab3887491172f
diff --git a/kde-apps/lokalize/lokalize-19.04.0.ebuild b/kde-apps/lokalize/lokalize-19.04.0.ebuild
new file mode 100644
index 000000000000..1ad287eef370
--- /dev/null
+++ b/kde-apps/lokalize/lokalize-19.04.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit python-single-r1 kde5
+
+DESCRIPTION="KDE Applications 5 translation tool"
+HOMEPAGE="https://kde.org/applications/development/lokalize
+https://l10n.kde.org/tools/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kross)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qtsql 'sqlite')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ >=app-text/hunspell-1.2.8:=
+"
+RDEPEND="${DEPEND}
+ dev-python/translate-toolkit[${PYTHON_USEDEP}]
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_install() {
+ kde5_src_install
+ python_fix_shebang "${ED}/usr/share/${PN}"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ has_version dev-vcs/subversion || \
+ elog "To be able to autofetch KDE translations in new project wizard, install dev-vcs/subversion."
+}