summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:50 +0100
commit69bda468b16a78ac6fcd84b1c08671bc6ea74726 (patch)
treeffa226d7d06da09349b8cb8129a85a23ce627174 /kde-apps/lskat
parentecm.eclass: Drop KDE Applications 19.08.3 support (diff)
downloadgentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.gz
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.bz2
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.zip
kde-apps: Re-add KDE Applications 19.08.3 for arm64 only
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/lskat')
-rw-r--r--kde-apps/lskat/Manifest1
-rw-r--r--kde-apps/lskat/files/lskat-19.08.3-qt-5.14-1.patch83
-rw-r--r--kde-apps/lskat/files/lskat-19.08.3-qt-5.14-2.patch24
-rw-r--r--kde-apps/lskat/lskat-19.08.3.ebuild38
4 files changed, 146 insertions, 0 deletions
diff --git a/kde-apps/lskat/Manifest b/kde-apps/lskat/Manifest
index 7886a21520a2..f01054834464 100644
--- a/kde-apps/lskat/Manifest
+++ b/kde-apps/lskat/Manifest
@@ -1 +1,2 @@
+DIST lskat-19.08.3.tar.xz 1219400 BLAKE2B fd7b2b196a8a7fb279f41c9a42f8e942c52420495babc592ac841056f5fa8a0097d0ee841d9de07595e9cc5ca0c8b474ab2047b29d0cbe379b98304f3280846a SHA512 460bc794627fe612fd2fb7a4949d8c74e4b6ca729db9ec7837a9f988ca1dccb192822814d5c4911cf890dc86ae3314903bbd82263a1a892811dc4fcd2501f6e0
DIST lskat-19.12.3.tar.xz 1218840 BLAKE2B 4e6a352123230dcbef67f85b519ad220c7723b215c9fce2b89938c2b4b0de00326ef427fb410de3432b1e288e9e5c5d5dcb38090320c4a443ca1c78098fdc736 SHA512 84aebdbdbc3e7a85799cd4495c12c7f746a2745a353eeef48eca69242557762619fdd117fcf6581811e51700b5cde3b5c3b0cd1fbedceae529c2e925f0cc5fed
diff --git a/kde-apps/lskat/files/lskat-19.08.3-qt-5.14-1.patch b/kde-apps/lskat/files/lskat-19.08.3-qt-5.14-1.patch
new file mode 100644
index 000000000000..0e819d33161c
--- /dev/null
+++ b/kde-apps/lskat/files/lskat-19.08.3-qt-5.14-1.patch
@@ -0,0 +1,83 @@
+From d2eae3d524bf84b843eacdf45ecfc77908e12ad8 Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Tue, 17 Sep 2019 13:39:55 +0200
+Subject: Make it compiles against qt5.14
+
+---
+ src/gameview.cpp | 10 +++++-----
+ src/gameview.h | 4 ++--
+ 2 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/gameview.cpp b/src/gameview.cpp
+index 69c94a7..a9bbbac 100644
+--- a/src/gameview.cpp
++++ b/src/gameview.cpp
+@@ -26,7 +26,7 @@
+ // Qt includes
+ #include <QPoint>
+ #include <QTimer>
+-#include <QTime>
++#include <QElapsedTimer>
+
+ // KDE includes
+
+@@ -95,7 +95,7 @@ GameView::~GameView()
+ void GameView::updateAndAdvance()
+ {
+ static int elapsed = -1;
+- static QTime timer;
++ static QElapsedTimer timer;
+ if (elapsed < 0)
+ {
+ timer.start();
+@@ -118,7 +118,7 @@ void GameView::updateAndAdvance()
+ // Slot called by the framework when the window is resized.
+ void GameView::resizeEvent(QResizeEvent *e)
+ {
+- QTime t;
++ QElapsedTimer t;
+ t.start();
+ if (global_debug > 2) qCDebug(LSKAT_LOG) << "RESIZE EVENT " << e->size() << " oldSize="<< e->oldSize() << " at " << t.msecsTo(mTimeStart);
+ double diffW = double(e->oldSize().width() - e->size().width());
+@@ -182,7 +182,7 @@ void GameView::rescaleTheme()
+ return;
+ }
+
+- QTime t;
++ QElapsedTimer t;
+ t.start();
+
+ if (global_debug > 2) qCDebug(LSKAT_LOG) << "Theme queue rescale start at " << t.msecsTo(mTimeStart);
+@@ -217,7 +217,7 @@ void GameView::mouseReleaseEvent(QMouseEvent *ev)
+
+ void GameView::drawItems(QPainter *painter, int numItems, QGraphicsItem *items[], const QStyleOptionGraphicsItem options[])
+ {
+- QTime time;
++ QElapsedTimer time;
+ time.start();
+ QGraphicsView::drawItems(painter, numItems, items, options);
+
+diff --git a/src/gameview.h b/src/gameview.h
+index 8c5c995..d2da977 100644
+--- a/src/gameview.h
++++ b/src/gameview.h
+@@ -31,7 +31,7 @@
+ #include <QPoint>
+ #include <QResizeEvent>
+ #include <QSize>
+-#include <QTime>
++#include <QElapsedTimer>
+ #include <QWidget>
+
+ // Forward declaration
+@@ -116,7 +116,7 @@ private:
+ // Active input offset
+ QPoint mInputOffset;
+ // Theme queue delay time [ms]
+- QTime mTimeStart;
++ QElapsedTimer mTimeStart;
+ // Debug frame rate sprite
+ QGraphicsTextItem *mFrameSprite;
+ // Time between updates
+--
+cgit v1.1
diff --git a/kde-apps/lskat/files/lskat-19.08.3-qt-5.14-2.patch b/kde-apps/lskat/files/lskat-19.08.3-qt-5.14-2.patch
new file mode 100644
index 000000000000..2e8c9454246f
--- /dev/null
+++ b/kde-apps/lskat/files/lskat-19.08.3-qt-5.14-2.patch
@@ -0,0 +1,24 @@
+From 7361a17fa8ffe607ad7f050062a5e4a1eda24f26 Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Wed, 30 Oct 2019 13:33:58 +0100
+Subject: Make it compile against qt5.15, This enum is unused
+
+---
+ src/gameview.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gameview.cpp b/src/gameview.cpp
+index a9bbbac..2ca126d 100644
+--- a/src/gameview.cpp
++++ b/src/gameview.cpp
+@@ -52,7 +52,7 @@ GameView::GameView(const QSize &size, int advancePeriod, QGraphicsScene *scene,
+ // Cache on
+ setCacheMode(QGraphicsView::CacheBackground);
+ setViewportUpdateMode(QGraphicsView::SmartViewportUpdate);
+- setOptimizationFlags(QGraphicsView::DontClipPainter |
++ setOptimizationFlags(
+ QGraphicsView::DontSavePainterState |
+ QGraphicsView::DontAdjustForAntialiasing);
+
+--
+cgit v1.1
diff --git a/kde-apps/lskat/lskat-19.08.3.ebuild b/kde-apps/lskat/lskat-19.08.3.ebuild
new file mode 100644
index 000000000000..19ebb145a170
--- /dev/null
+++ b/kde-apps/lskat/lskat-19.08.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+KDE_SELINUX_MODULE="games"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Skat game by KDE"
+HOMEPAGE="
+ https://kde.org/applications/games/lskat/
+ https://games.kde.org/game.php?game=lskat
+"
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="arm64"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-apps/libkdegames-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-qt-5.14-{1,2}.patch )