summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-10 21:19:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-12 23:13:15 +0200
commit83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b (patch)
treeb45546dce283baad7492c85797d5bc6f8e535918 /kde-apps/pimcommon
parentkde-frameworks: Add KDE Frameworks 5.63.0 (diff)
downloadgentoo-83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b.tar.gz
gentoo-83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b.tar.bz2
gentoo-83cbb66d1cb4a7b7306bab52afbc0306bdfcf83b.zip
kde-apps: Add KDE Applications 19.08.2
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-19.08.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index 1c78b038bf3c..71fe971a44cd 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1,2 +1,3 @@
DIST pimcommon-19.04.3.tar.xz 294420 BLAKE2B 87d67b7dd975b0d989b5ca408e478cfed68918b1451f5faf16538d5fdd5033c00b1b98b07c8b75183ee83b21fa929aed94473a2935075886ff78db85c1589881 SHA512 862d240de0b551035eddf03cbbfe381c7a11c0715e4a0159447197525e5f68cf62ddc716726e1229f5be9e99c6c5129db8ed87aa8e8d0b713a23698a81884f27
DIST pimcommon-19.08.1.tar.xz 293872 BLAKE2B c48ef7304fdc3e172bf68d885d7ce9aba3ec9f38ba5dec17ac03dd4e636cc165cdfa3dcb6e2ca36e840c4c489757df17a8924d74d57882f21ea71ed3debae1d6 SHA512 bd32b3d7cbd0dcd3f539037c92227df655874b296ed1d7501255ce470b2a8692d53bf0848a765bf901f173d36f7b580cddcdf4a33f1c903a5280f1a99184846f
+DIST pimcommon-19.08.2.tar.xz 293952 BLAKE2B d108ac861071c3119c9fc78709ec8c368d783329598a87d711702cedce26dad9369374dd9b16a33c86886143bf64a71ec7949bf60bf90bdbc1ce28ab85f32c68 SHA512 e36be359a524e747f22cf11f411fd053c43636e1e0758192bb9b8c2ea577dd116f9ac8471328ee986f19d0327edde58a7d3563f7ce36e3e2fad967b0d8b9fbb7
diff --git a/kde-apps/pimcommon/pimcommon-19.08.2.ebuild b/kde-apps/pimcommon/pimcommon-19.08.2.ebuild
new file mode 100644
index 000000000000..e8f9a1e6a4f7
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-19.08.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Common PIM libraries"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcontacts)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep purpose)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kpimtextedit)
+ $(add_kdeapps_dep libkdepim)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kiconthemes)
+ test? ( $(add_kdeapps_dep kmime) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-common-libs:4
+ !kde-apps/kdepim-l10n
+"
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatortest)"
+ )
+
+ kde5_src_test
+}