summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 16:04:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 17:06:07 +0200
commit8ea97068f86f7c38eb7eba7b4834d24395ea63c8 (patch)
tree1a99302b57a044d70ab6ffc235920f12cd030996 /kde-apps/print-manager
parentdev-texlive/texlive-luatex: Add more blockers (diff)
downloadgentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.gz
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.bz2
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.zip
kde-apps: Add KDE Applications 19.04.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-19.04.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 68b57fe6ef0a..a7465e323cfd 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-18.12.3.tar.xz 238832 BLAKE2B afaa1babca0cacd017b1ca9fbac6c3e691a56835e390308e2713969da2b5d4a3c209c9e27f9043508389c494232c93f192d1f0d0da92327ff99c136dcf47db15 SHA512 c801a42ea0dc94fe5aa6e9cbb5a06f164e7d2137bc2458541ace25349fd4c1b748cdb229994e3fbb85bdf86ab1b6ba7757b2060aaff060ea0e4bad7f35532c67
DIST print-manager-19.04.1.tar.xz 239284 BLAKE2B 7e20e73abee86782855ac67636428a1aa46b88aed21a9225f579ab40d7f03abf9159b56003fd9d31b990546d7b6c8bfe30a1587cb82a95838cb4f7eadf21c0f0 SHA512 ce59f2e1dc4cc385fde00ea5a6306df01f17754e628cbe4d10e1bf9a0696f1e3e7b93999977b801ff5b3a7a9abdec5e76f6a7818c5a2b2878b293046c9b22e50
+DIST print-manager-19.04.2.tar.xz 240472 BLAKE2B 7f4e360228ca31afd73740ed6e46be95cd37eaac4b54434ae59119b6c87b45049cfadddf6ec80dbad0d9fe95cc6bcf4aabbf78215129d208291365be162797a4 SHA512 e7f3033153d930b3e811988fb13b18dc9dd27ae0893a3c8926a260b27f9bf505a78b8c8449eb7565aa160c97426f189fe7cc60d86ddc2d699f6ecbfe33918d55
diff --git a/kde-apps/print-manager/print-manager-19.04.2.ebuild b/kde-apps/print-manager/print-manager-19.04.2.ebuild
new file mode 100644
index 000000000000..1ae66560761e
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-19.04.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}