summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:34:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:36:38 +0100
commitc1941078fbe8744f0710332dee5705d3a95a800b (patch)
tree2fbace875e510011c2845a85071b60cf371926d5 /kde-apps/print-manager
parentapp-emulation/xen-tools: drop old (diff)
downloadgentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.gz
gentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.bz2
gentoo-c1941078fbe8744f0710332dee5705d3a95a800b.zip
kde-apps: Add KDE Applications 18.12.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-18.12.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 2ce75be31e39..d92b2d7c5ad2 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-18.08.3.tar.xz 238796 BLAKE2B f3fe67bb2a6b7f2e05b7ed8934ba491a829eff842fdd1f76af3cc376e679826e6ae1f332242d278215828b4842a0bf85b6e22d5b3ffb03d61f01c5f575cfa0d1 SHA512 0727f5e125ac2198276a92acfd881077647ab082b5edc9c4e5211f53dccd19e12b9b6934fd696424e029d5f7de373a194f9c302f587fb0c80af42526cd4a04ad
DIST print-manager-18.12.2.tar.xz 238864 BLAKE2B 0470b3d34b7eba6d510b86670eae0fb196a1fbba6fc44531c6998fcdfc1977f4d2962113ec850e67ae57dcab7d4569da1ee0bdcb362e89ce4ca9fa729783af05 SHA512 10cfa342804820c516e50d55fdda1046b4cfefb24e9d1d32c633471435e0740d160df01a7a3b2e67feb4411f5baeefc9716fdd798f4efd9506e14cd3acce4633
+DIST print-manager-18.12.3.tar.xz 238832 BLAKE2B afaa1babca0cacd017b1ca9fbac6c3e691a56835e390308e2713969da2b5d4a3c209c9e27f9043508389c494232c93f192d1f0d0da92327ff99c136dcf47db15 SHA512 c801a42ea0dc94fe5aa6e9cbb5a06f164e7d2137bc2458541ace25349fd4c1b748cdb229994e3fbb85bdf86ab1b6ba7757b2060aaff060ea0e4bad7f35532c67
diff --git a/kde-apps/print-manager/print-manager-18.12.3.ebuild b/kde-apps/print-manager/print-manager-18.12.3.ebuild
new file mode 100644
index 000000000000..1ae66560761e
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-18.12.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}