summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 16:04:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 17:06:07 +0200
commit8ea97068f86f7c38eb7eba7b4834d24395ea63c8 (patch)
tree1a99302b57a044d70ab6ffc235920f12cd030996 /kde-apps/step
parentdev-texlive/texlive-luatex: Add more blockers (diff)
downloadgentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.gz
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.bz2
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.zip
kde-apps: Add KDE Applications 19.04.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'kde-apps/step')
-rw-r--r--kde-apps/step/Manifest1
-rw-r--r--kde-apps/step/step-19.04.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-apps/step/Manifest b/kde-apps/step/Manifest
index c021a76f8ea7..d507dccba389 100644
--- a/kde-apps/step/Manifest
+++ b/kde-apps/step/Manifest
@@ -1,2 +1,3 @@
DIST step-18.12.3.tar.xz 860296 BLAKE2B 7a6411334758c0277c12401d2d22112c0e3e2befb2cdef68694ac4ba3544329a007b9db2a5607564ef2710b2282a2d72a4c4a0de945de3361b6dd4b400b71ef7 SHA512 5ac3ab33d48aa4d151ea7152a380aba95eabc7887400d20fe50392a6c18a5017b162208c47d8de6d019e8a462608a2f4da3bacaa64cbc966770971b6a55b1b82
DIST step-19.04.1.tar.xz 859804 BLAKE2B 1424c75c2d37832c4467ac07cdafe74586c8cc64f09e3e9a930a4c346220bd1ae5c51b529bb0f7b19cdb7b30b8cccf3cea6b2e68d0ceaa5a2fc86db5fb6cd6de SHA512 d3744c0c5cee20cae0b3f51ce68fcea5ae74091f55a02acea5009f1f70902f5666fbb67f20db1b17d1bbaeee6d6d8cdeea4c2d5a79239c3297febb3b7bc3fd7d
+DIST step-19.04.2.tar.xz 860480 BLAKE2B 36f4d4039cee68a65dec1adc40d5d9c2bdb055de810762019ffff6aec063667b68019a0cf0f4897a7ac8a3e35424b248a198fc91d0348464839f1f5815173c1a SHA512 1b48f40f58315dd1126861b18ecf783c2f7994ae046377c14039676015e4a30d5cdad13bc5e52a822b1ee69786b52152b79210a4986a9c41431243b3d41eedc6
diff --git a/kde-apps/step/step-19.04.2.ebuild b/kde-apps/step/step-19.04.2.ebuild
new file mode 100644
index 000000000000..0c8734816df7
--- /dev/null
+++ b/kde-apps/step/step-19.04.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="optional"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Interactive physics simulator"
+HOMEPAGE="https://edu.kde.org/step/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+gsl nls +qalculate"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kplotting)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtopengl)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ >=dev-cpp/eigen-3.2:3
+ sci-libs/cln
+ gsl? ( sci-libs/gsl:= )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ # FIXME: Drop duplicate upstream
+ sed -e '/find_package.*Xml Test/ s/^/#/' \
+ -i stepcore/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gsl GSL)
+ $(cmake-utils_use_find_package qalculate Qalculate)
+ )
+ kde5_src_configure
+}